TTS service not working

Hello

I have an issue with the TTS feature. When I type it in the media player service it makes my assistances and Sonos wake up but it doesn’t say anything.

I can see that the .mp3 file has been created and lives in the tts folder within the config directory.

I don’t see any errors in my log files to suggest something is wrong. I am using Hassio and tried this with Google Cloud Services and Microsoft’s too.

Cheers

I have had the same issue for awhile but hadn’t gotten around to investigation.
Developers State Attributes which shows the sound file being generated,

volume_level: 0.4699999988079071
is_volume_muted: false
media_content_id: https://192...**/api/tts_proxy/ae1e75c7c8b90c49ace80acb1ec47488e278f53f_en-us_a9c18110b0_cloud.mp3
media_position: 0
media_position_updated_at: 2020-08-11T22:21:31.582735+00:00
app_id: CC1AD845
app_name: Default Media Receiver
entity_picture_local: null
friendly_name: Kitchen Speaker
supported_features: 21391

This is my tts configl in configuration.yaml

tts:
  - platform: google_translate
    cache: true
    cache_dir: /tmp/tts
    time_memory: 300
    base_url: https://192.***.**.***
    service_name: google_say

I have tried different base_url addresses using 8123 port etc but if the mp3 file is being generated then I assume the bas_url is ok?

You cant use https if you are going to use an address that can’t be validated.

Either use http internally, or use the external https address.