Turn single led on when switch gets turned on

I installed a 4 channel relay in a box and i want to have an indicator light to turn on when each of the relay channels gets toggled on. I have 4 leds, 1 for each channel. They are red leds which are already soldered to 1k resistors. I can already make it work through an automation in esphome, but i’m sure there is a better way to do this. I am using an esp32s, a 4 channel relay, 4 solenoid valves with flyback diodes installed and a 12v psu plus the 4 leds in question.

I thought this code would work but the led still dont light up… I see both the led and the switch toggle get activated and turned off on the "esp32s web server page but no light is happening…

esphome:
  name: relay4ch_01
  platform: ESP32
  board: nodemcu-32s

wifi:
  ssid: "Netgear_dd"
  password: ~~~~~~~~~~~~~~~~

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Relay4Ch 01 Fallback Hotspot"
    password: ~~~~~~~~~~~~~

captive_portal:

web_server:
  port: 80
# Enable logging
logger:

# Enable Home Assistant API
api:
  password: ~~~~~~~~~~~~~~~~~~

ota:
  password: ~~~~~~~~~~~~~~~
switch:
  - platform: gpio
    pin: 25
    inverted: true
    name: "relay1"
    icon: mdi:sprinkler
    id: valve1
    on_turn_on:
      then:
        - light.turn_on: led1
    on_turn_off:
      then:
        - light.turn_off: led1
  - platform: gpio
    pin: 26
    inverted: true
    name: "relay2"
    id: valve2
  - platform: gpio
    pin: 27
    inverted: true
    name: "relay3"
    id: valve3
output:
  - platform: ledc
    pin: GPIO33
    id: gpio_33
  - platform: ledc
    pin: GPIO32
    id: gpio_32
  - platform: ledc
    pin: GPIO14
    id: gpio_14
light:
  - platform: monochromatic
    output: gpio_32
    id: led1
    name: "LED1"
  - platform: monochromatic
    output: gpio_33
    id: LED2
    name: "LED2"
  - platform: monochromatic
    output: gpio_14
    id: led3
    name: "LED3"

I’m sure it’s a little detail i didn’t see or something stupid… been trying to do this for months now
Thanks in advance

What is the ledc output brightness set to?

Try:

    on_turn_on:
      then:
        - light.turn_on: led1
          brightness: 100%