Tuya device appears in Tuya app but not Tuya integration

Tags: #<Tag:0x00007f32682cbe00>

I just bought this OSOWOO Water Detector.
I was able to add the device to the Tuya app but I cannot get it to appear in the HA Tuya integration.
(I current have 11 Tuya devices in the app that do appear in the HA integration)

Not all Tuya devices are supported by the Tuya integration.

Oh… interesting… I didn’t know that

buenas … como habeis integrado tuya en home assistant?

me pide usuario y contraseña … en usuario meto el correo y la contraseña con el codigo de mi pais y SMARTLIFE y no me funciona…

Gracias

I had an issue before with a switch not visible, it was caused by spaces in the device name in tuya, i removed it, and it became visible

Tuya is not working anymore? I have try to setup my smart live account and I see on the logs that tuya is not supported :expressionless: how can I discover my smart life devices?

Hi,

Happy to discover others are experiencing this problem, as I too recently bought this wifi door sensor (box states model #: S4381) which states it’s compatible with the Tuya app:
https://www.amazon.ca/gp/product/B08573CTFK/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1

I created a post about smart bulbs I bought (nooie brand) which did not integrate with HA, but once I realized they can work with Tuya app - they integrated np with HA.

While this door sensor gets added in the Tuya np, it does not get discovered in HA, and I tried removing the spaces in the device name as mentioned above but still no luck :frowning:

I just removed and re-added the Tuya integration and waiting for HA to update the discovered devices. Will let you know if it works out. If anyone has any other ideas please post!

Thanks!
-M

Any way to do something with this issue? Is there anybody who could help? I have also a robot cleaner, which can be managed by smart life or Alexa but not by HA.