Tuya double button switch unavailable

So out of nowhere, my double switch (wired), that controls my living room lights, is unavailable in HA. It works fine with SmartLife app, state updates, it turns off and on. It is the only double switch in my house - all others are single and work fine - if I remove and add, etc, tried same things with them - they appear fine.

What I tried to do:

  • Remove the device from smartlife app and add it again
  • Remove the gateway from smartlife app and add it again
  • Move every device, including my double switch to Tuya app - no help
  • Remove the device entities from HA, restart a million times, try to add it again, it did not show up at all when I removed the Tuya integration and added it again - so I restored my snapshot from yesterday to atleast see the entity.
  • Restarting HA, my intel nuc with HA on it, restart my whole home network.

There is no particular error about anything Tuya related in the logs. This happened completely random, my internet went out for a bit, and then all of sudden that switch shows up as unavailable.
Any help is very much appreciated, been stuck whole day on this, and am super frustrated. Thanks.

I have solved this on my own. Turns out I needed to rename the seperate switches (not the whole switch, but the two switches inside it - I had Switch 1 and Switch 2 and renamed them to Light 1 and Light 2) in the SmartLife app and then restart HA. Entities appeared again and life is good. I have no idea why this happened.

1 Like