Tuya Zigbee Smart Knob stops sending events

Anyone had any luck with the Tuya Zigbee Smart Knob?

For me, it paired just fine and even was issuing events properly. Then I woke up the next morning to it being totally unresponsive and issuing no zigbee commands.

I’m using Node-Red, the Sonoff Zigbee Pro stick, and ZHA.

I am having a similar problem. I just tried to set this up today. ZHA added a device with battery entity successfully, but I haven’t been able to see any events in zha_event. I’m hoping for an easy fix.

I ordered 2 of them. The second paired and continued to send events. Sadly, not all the events are supported. It only registers the single-click and the rotate left/right. Press & rotate isn’t supported. Nor are double or triple click. I have a feeling that this device needs a quirk and I have no idea how to make them.

it has two modes, you can “triple click” to toggle between them. One recognizes a few commands and one does nothing (as far as zha_event is concerned). So try 3x fast clicks then listen to zha_event

I’m in the same boat as @JDHayes though. Only get events for single click and rotate. Using Nortek stick w/ ZHA.

Having the same problem, anyone find a solution?

Try doing a triple-click and see if it will send events then. The knob seems to have two modes. One of the supports a single press and rotate events. When you triple-click, you get into the other mode and HA doesn’t handle it properly.

Tried triple click to attempt and change mode, events just don’t show up. I will put this in a box and attempt to set it up later. You are correct that it has two modes and it does seem to be stuck in a certain mode that is not supported.

I’m just trying to setup one of these. Paired fine with my tasmotized Sonoff zigbee bridge.

Single clicks and rotating doesn’t generate zha_events regardless of mode.

Triple-click does seem to switch modes, and generates a zha_event (below) but nothing else does.

    "event_type": "zha_event",
    "data": {
        "device_ieee": "54:0f:57:ff:fe:2e:2a:ff",
        "unique_id": "54:0f:57:ff:fe:2e:2a:ff:1:0x0006",
        "device_id": "7ed1205115d66c19fefc47d113a5898b",
        "endpoint_id": 1,
        "cluster_id": 6,
        "command": "attribute_updated",
        "args": {
            "attribute_id": 32772,
            "attribute_name": "Unknown",
            "value": 1
    "origin": "LOCAL",
    "time_fired": "2022-03-25T06:30:57.846299+00:00",
    "context": {
        "id": "67b66fa4c6cd0f4720e5959659fc806d",
        "parent_id": null,
        "user_id": null

Anyone else have this problem?

1 Like

I just installed one. I can toggle my light with a single click, change brightness by rotating, and toggle my fan with a double click. I cannot get the long press to work.