Unable to access TP-Link Kasa devices on new TP-Link Deco system

I have a lot of TP-Link Kasa devices in my home. When I first installed HA, it automatically discovered all of them. I was using a 4-year-old TP-Link Deco mesh system at the time.

For reasons unrelated to HA, I had to replace that system. I replaced it with a newer TP-Link Deco system, X55. Once that was installed, HA could no longer access the Kasa devices. It still sees all my other IoT devices.

I removed all the Kasa devices from HA and tried to rediscover them; no luck. I tried using each device’s IP address for the host to discover them. When I used 192.168.68.67, e.g., I get this error message:

Connection error: Unable to connect to the device: 192.168.68.67:9999: [Erno 113] Connect call failed (‘192.168.68.67’, 9999)

I’ve rebooted at all places, including resetting a couple of the Kasa devices to see if that worked. My sneaking suspicion is that this new Deco system has a Smart Devices Manager in the app, which only recognizes my Kasa devices on my network (none of the other IoT devices), and somehow that’s interfering with HA’s access to these devices.

I am at a loss now of what to try next. I’m currently waiting for customer support from TP-Link to see if there’s a way to turn this Smart Device manager off in the Deco app.

I’m not a sophisticated user, so any advice is much appreciated. Thanks!

I’ve managed to make some progress, but not much. I did manage to remove my Kasa devices from the Deco app management by “removing” each one. This deleted the custom name for each so that now each shows as its generic model type on my network (e.g., KL110).

After I did that, HA found nine of the 14 devices automatically. It still won’t find the other five. Every week or so, it discovers a new one on its own, so maybe someday it’ll find all of them.

However, I still get the error “Failed setup, will retry” for all of the ones it has found. When I reload, it goes through the initializing stage, then right back to “Failed setup, will retry.” I have debug logging on, but I don’t see any logs for these devices in my logs. When I go to a specific device, it indicates “No logbook events found.”

I’m still able to control these devices via the Kasa app, but I can’t incorporate them into any HA automations.

Any help or suggestions is much appreciated. Thanks!

Did you ever find a solution to this?