Unable to add home assistant devices into Google Home

Hi everyone, I was wondering if someone could explain why I can no longer add my home assistant to Google Home. Everything used to work back in September 2022 when I initially set up the integration but now I cannot log into the ‘Works with Google’ integration. I’m not using Nabu Casa and instead followed Everything Smart Home’s tutorial. I also use a Cloudflare URL to access my Home Assistant instead of forwarding ports.

I set everything up in Google Actions and Google Console and when I click on ‘Works with Google’ to add the devices, I get the Home Assistant login screen as I should do. However, when I try and log in (using 1Password) I get an invalid username or password error. I have tested my logins and they definitely are correct and also work on the external site for my HA. I was wondering if it was to do with my 2FA for my HA account (even though it worked in September) so I tried another account without 2FA and I still got an incorrect login error.

I was wondering if anyone knew if Google had changed anything or if there are now new steps I need to do to get my devices to show in Google Home again.

My HA config is:

    project_id: homeassistant-551f7
    service_account: !include SERVICE_ACCOUNT.json
    report_state: true

I’ve tried re-creating another project and following the tutorial again but still getting incorrect username and password. If anyone could help I would be soooooo grateful!!

Thanks for taking the time to read my post.

If upgrading to version 2023.5 caused the issue, the following link might shed some light on the issue.

The responses in the issue are not very promising.
I hope they don’t “forget” about the self-hosted google-assistant integration in favor of “marketing” the cloud solution.