Unable to Change Default Bitrate of Audio Output

Hello Community,

I’m experiencing issues with changing the default bitrate of my audio output in Home Assistant OS. Despite multiple attempts to modify the configuration, the default bitrate remains unchanged at 44100 Hz.

Problem Description:

I have a sound card connected to my Home Assistant OS setup, and I hear crackling noises during music playback. It has been tested on another device and works without any issues. I suspect this might be related to the audio bitrate settings. I wanted to change the default bitrate from 44100 Hz to 48000 Hz to validate.

I have edited /etc/pulse/daemon.conf:

default-sample-rate = 48000
alternate-sample-rate = 48000

but the settings did not take effect after ha audio restart.

pactl info still shows:

Default Sample Specification: s16le 2ch 44100Hz

Full output here (apologies for the screenshot, I don’t know how to copy from SSH):

Any guidance on how to resolve this issue would be greatly appreciated.