Unable to download ESPHome binary file without restarting hassio first :(

Not sure what’s going on… running hassio with docker. When I create a new ESPHome configuration/device, everything seems to work ok, it compiles fine, but I cannot download the binary until I restart my server via docker restart homeassistant. What gives?
image

Have you tried just reloading the page cache before compiling (Ctrl+Shift+R or Ctrl+F5)?
Which web browser are you using?

1 Like

Home assistant is completely separate to esphome.

You know, that might’ve been the answer. I just created a ‘test’ image and after hitting Edit - I got a 404 error - I hit refresh, and then was able to edit it. Perhaps that’s the issue all along, because then I was able to compile & download. I’ll just have to remember to hit refresh first next time. Browser - Chrome on macOS.

Uh… completely separate? They’re integrated pretty tightly… and I access all the configuration pages from within homeassistant… so… thanks for the helpful comment, dude :wink:

But you do not have to. They run in completely separate containers, on different ports. Restarting home assistant does nothing to esphome.

Always happy to help.

ok :slight_smile:

I have found that much weirdness with ESPHome (and indeed, with HA in general) can be fixed by refreshing the page. And it really does depend which browser you’re using.

For example, in PaleMoon, ESPHome (and HA) performs like a pig trying to wade through a vat of treacle. In Firefox, greased lightning.

But whatever the browser, there’s a weirdness when I add a new device: it’ll appear in the list, but it will 404 if I try to edit it. Quick F5, the problem goes away. Something to do with arrays, probably.

Point is, CTRL+F5 is your friend.

I have the same problem, but instead of restarting hassio, I restart the addon

the refresh regarding the download does not work, remains download.txt

I like the idea of refreshing the addon. Wonder what the problem is, though.

Thanks @tom_l, this worked for me. Having been frustrated for ages by this simple issue, a simple CTRL-F5 before compiling the binary fixed the download problem.

had the same issue shift + F5 was my (temp) solutions as well. Thanks!

Nudge +1
I’m new to HA and ESP32’s. Just to inform other peoples who are like me, it still has the same issue - press F5 for refresh, and try try to download the firmware again.

In general you don’t even need to download the binary. Esphome uploads it to your esp device.

I’m unaware of how to flash a factory-new device without first downloading the firmware file and then flashing the device from my laptop (I run HA on a separate server). If I’m doing something wrong, please enlighten me/us.

Plug it into your server’s usb port

That just won’t work for me.
Don’t know why…

Refreshing browser before compiling worked for me. Download binary opened the Windows download dialog. (Firefox).