Unable to flash Sonoff devices, what am I doing wrong?!

Hi all,

Unfortunately I am having no luck at all in being able to flash anything to my Sonoff TH10 and Sonoff RF Bridge via serial.

In terms of serial adapters, I have a CH340G based USB to TTL (https://www.amazon.co.uk/dp/B01MR7N2TR) and an Arduino Uno R3, both of which successfully complete a loopback test.

My CH340G adapter is correctly outputting 3.3v on VCC but weirdly 3.6v on RX/TX. My Uno is kicking out out 5v on RX/TX.

As the ESP is sensitive to 5v, I have some Logic Level Converters (https://smile.amazon.co.uk/dp/B07PY3CRFM) to try and pull the RX/TX down to 3.3v, however I’m not 100% sure if I’ve wired that up correctly.

Software wise, I’ve tried esptool, easy esp, tasmota pyflasher, arduino ide etc all using the values suggested by Tasmota’s Wiki but again, with the same result.

Anything using esptool results in “……”, which flashes the RX led on the serial adapter/uno as it does.

Could any kind soul possibly point me in the right direction in terms of wiring these up?

If I were to have fried the ESP, would this affect the normal operation of the existing firmware?

Many thanks :slight_smile:

Did you press the button while connecting your USBTTL in the usb ? If not, the esp does not enter flash mode.

Ditto, You were faster :slight_smile:

Certainly did. I also double checked that it was grounding correctly when pressing by doing a continuity check.

Is there a way to check that it is in Flash mode?