Unable to HA reboot via UI

Running HA OS 7.6 and Core 4.1 on a Proxmux. I noticed that the restart button from the config → server control stopped working (not sure when). Config is valid, and when pressed, it seems to stall completely (UI stops working and doesn’t come back online; I reboot via Proxmox to get it back online). I initially though it had to do with lack of memory, but I have plenty free (using 1/2 out of 14 Mb currently allocated). Nothing is visable in the error logs. Anybody can help me resolve this? Thanks!

Just had something similar, Home Assistant UI was hanging any time I tried to view dashboards so I attempted a reboot…and it hung.

Since I’m running a VM I was able to log into the hypervisor and grab a screenshot but I don’t know what to look to debug. Didn’t see anything in logs, but I did notice when I pulled up the VM the disk I/O line was FAR higher than normal in throughput and I don’t know why.

Manual reboot on my Linux hypervisor got it to come back to life and no more silly-high disk I/O, but I worry it may happen again. I also notice that history graphs since it came back up are truncated starting from the last state-change vs showing the full expected duration, but I don’t know if this is related to how it got stuck.

HA OS 7.6, Core 2022.4.0

Hi Matt, I also have this message when I reboot my HASS VM in Proxmox. Not sure how this is related, this would not be triggered via an UI Restart, or would it?

Anybody else ideas what is going on here? My free RAM does show a bit of a funky flow today (in the beginning at the max of the VM).

Not sure. I tried to restart thru the configuration UI.

So far (knock on wood) no other odd issues reoccurring…though I don’t have a sensor to plot memory like you do. My hypervisor reports usual low CPU/RAM/Disk IO as usual ever since I did the forced reset.

You can set it up using yaml.

sensor:
  - platform: systemmonitor
    resources:
      - type: disk_use_percent
        arg: /config
      - type: memory_free

I seem t be hitting almost 0 free ram once/twice during the day. And then it bumbs up to ~ 15mb (provided by Proxmox).

No change, I can still not reboot from the UI

Mmm, was now getting this in the console

Anybody able to help us on this? Pretty annoying that we cannot restart from the UI and have the restart from Proxmox when changing yaml settings.

Thanks!

I see you are out of memory,
I had that to, how much did u configure the ram in VM?

Mine is set to 3000mb and 2 processor.
But i’m using virtualbox.

And do you think that is the reason for not being able to restart from the UI?

I have almost 15gb assigned so really don’t understand why this is insufficient. How can I analyse this further?

Docker stats doesn’t really help me

Free memory pattern looks odd to me

Thanks!

Maybe i can try to help you,

So when u click the restart button nothing happens ?

Yes that out of memory problem cuases home assistant to act weird and don’t get responsive…
That error can be caused by some other programs running on the same server and when it hits the max assigned memory u get that message…

I had it to, but i could restart home assistant tho.

Indeed, so now I have enough space left but still when I press restart nothing happens.

Looking at the docker stats I noticed that DeepStack is in the list, which is strange as I have removed this earlier. Let me see if it helps if I remove this.

There could be a problem with the database perhaps its to big.

I found another topic, with the same issue, but than on a raspberry pi.

see:

And HA is indeed acting weird. I cannot install other add-ons… it stalls after pressing install

image

Let me look into the other topic, thanks!

Well do this:

Create a backup, and do a fresh install and see if its gone.
Something is indeed wrong in your system.

Mmm, that is a last resort indeed. But with a backup, doesn’t it return into the same state and therefore issue?

Having never restored a back-up, what is the best way doing this? My backups/snapshots are on my NAS.

Thanks!

There is a possibility that the issue comes back, if it comes back than you know its from home assistant.
If not, its your VM

Well do this:

  1. Download the full backup, but DONT delete this VM yet, shutdown this VM
    2 use that backup on an other system just to check if everything is complete.
  2. If it works on another VM, than your current vm is broken.

Regards

Before I do all this, is there somebody that can show me a ‘normal’ memory usage profile? I want to understand why I am hitting the floor (while having 12-15 mb available in my VM). Thanks!