Unable to Install/Update addons

Tags: #<Tag:0x00007fc4199805c8> #<Tag:0x00007fc419980370>

I’m being unable to update some addons (samba share, esphome, mosquitto broker). When updating I recevie the following error:

401 Client Error for http+docker://localhost/v1.41/auth: Unauthorized (“Get https://registry-1.docker.io/v2/: unauthorized: incorrect username or password”)

I’ve also uninstalled the samba addon and now I receive this same error while trying to install it.

I do not understand what is going on but I’v updated my docker-engine up to de last version (20.10.6) and it apparetly works as suposed.

I’ve been searching around the forum but I’ve found no solution.

Any help will be appreciated!

Well… I’ve been a couple of days searching the solution to my problem and a couple of ours after posting I’ve found it. I leave it here for anybody with same problem.

I added the docker repository following these instruction Docker Hub Rate Limit - Home Assistant but the problem persisted. The username of my credentials was my email (which give access to docker webpage) but once I have changed it to my username everything worked again.