Unable to login using domain address

I have been using HA for a while by using the LAN IP address in the url with no issues. However I am now trying to setup a domain address to use both locally and externally. I have the requests hitting an NGinx reverse proxy.

My first attempt brought up the login screen but was unable to connect to HA. I got this error in the logs:

Logger: homeassistant.components.http.forwarded
Source: components/http/forwarded.py:121
Integration: HTTP (documentation, issues)
First occurred: 4:27:39 PM (1 occurrences)
Last logged: 4:27:39 PM

Received X-Forwarded-For header from an untrusted proxy

I researched and found that I needed to add the following to the configuration:

  use_x_forwarded_for: true

It is still unable to connect but now have a different log entry

Logger: homeassistant.components.http.ban
Source: components/http/ban.py:124
Integration: HTTP (documentation, issues)
First occurred: 4:38:37 PM (6 occurrences)
Last logged: 4:52:51 PM

Login attempt or request with invalid authentication from ( (Mozilla/5.0 (X11; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0)

I have verified that I am using the same credentials (using a password manager) for both for the IP and the domain address. I have tried to reset the password in both the Users and People pages (although I believe that both change the same password). I have tried in both Firefox and Chrome and have cleared site cookies/data many times.

I am not certain what to look at next. I have found a few different topics about problems with remote logins and they all mostly just deal with the firstly mentioned trusted proxies issue or with api creds, neither apply in my current state.

Any assistance would be greatly appreciated.

Did you configure both http and websockets in the nginx configuration ?

That was the answer! I did http but did not do websockets. Thank you very much for the solution.