Unable to make SSD image of HASSIO install

Hi All, first time poster :slight_smile:

So, I’ve been using HA as a docker image on Raspberry Pi OS for a year or so and decided to take the plunge to move to HASSIO. Well, it’s been a journey of discovery, I’ve solved almost all of the issues this caused me (except for being unable to run Python code to keep my Watchdog Timer UPS happy) but I’m left with a biggie.

I don’t trust backups, plus they leave you with a less than simple route to restoring your full system.

Up to now I’ve been taking full image copies of the SSD (over USB) I’m running on by plugging into a Windows machine and using a freebie tool.

This no longer works as I cannot mount the entire drive or even see all of the partitions now I’m running the Supervised HA.

I’ve tried mounting the full drive in Raspberry Pi Desktop running in a VM but PiOS is unable to mount the full drive and gives me errors (I may be attempting the impossible here as I’m a relative Linux newbie dumbie). I can see most of the partitions, I believe, individually but not as one disk, so cloning the drive to an image is not possible.

Does anyone use this method to backup their install and, if so, what process do you use?

Pretty please?

Many thanks, hoping there is a like-minded soul out there.

Paul

I really like this. Its easy and effective.

but I see this in your comments:

I’ve recovered numerous times from it. Not sure why you don’t trust this method?

You can take the SSD and use dd to copy the entire disk though. but that is pretty rough and manual.

Thanks for the reply.

I don’t mind rough and manual because the result is an exact copy of my SSD, which leaves me the option to quickly restore to a new SSD and boot up again in short order, I don’t mind having to use normal backups then to update the database if it’s a bit old but at least my config and subsystems will all be present.

I don’t trust backups fully because they don’t copy ALL of the config info (I’ve just been through the process by migrating my HA server to HASSIO and it did not backup or restore everything).

I’ll give the “dd” command a go and see how I get on with it.

Thanks again.

That isn’t quite correct. Not every SSD is the same size. you may not be able to restore that image even to the exact same model SSD. You’re going to be struggling if it is just one block less space. :slight_smile:

YEs they do. They backup all the config info.

It would but when you were running it as a docker image you likely had stuff outside of the HA space. Otherwise it would backup everything. Run a backup, open it up in a zip program and look at it.

ok, I’ll give that go.

It didn’t work for me when in docker images on a lot of the subsystems, don’t know why, but I ended up rebuilding a lot of them by scratch (this was by tar-ing up the entire docker volume for each subsystem then restoring over a fresh install on hassio docker images, not fun).

It may work better on hassio I just don’t trust it yet, I will test a full restore and see what happens.

I’ve tried restoring images happily onto four different SSDs with Macrium Reflect and it worked every time, it just can’t see all of the new hassio partitions. I’m guessing you’re probably right about not being able to restore images onto different drives with “dd” if it doesn’t resize the partitions to the new drive.

Many thanks, Paul

So I get ya. More than you know because in the beginning I was also imaging my entire disks so I knew I could restore them… (shutting HA, plugging them into my linux box, DD’ing the entire disk, starting HA whle I push that to the cloud)

I’ve found the backups are reliable but you need to feel comfortable with it. The restore mechanism is literally remiage the SSD with HASSIO. Then ‘restore’ the zip. Done. What it does under the covers is pulls down all the docker images again and restores your config directory including all addons.

Good Luck.

1 Like

Thanks, I appreciate it.

So I ran through a new HA Operating System install and updated/restored from my latest backup and it all worked! Yay!

My problems before must have been because I was moving from a Docker install of HA to a Supervised version.

So happy about that, makes things so much easier.