"Unable to Register Application"

Hello, I am trying to use the companion app for the first time. My HA is already able to be accessed from outside, and I added mobile_app: to my config.yaml

But the app is not connecting and it says that I should ensure that I added the mobile_app part to mi config.
What should I do?

Which version HA are you running?
What kind of installation? Hass.io?
Did you restart HA after adding mobile_app?
Any logs?

Hi. SOrry I was in a hurry and did not add a lot of details.
HA version is 0.103.4, its Hass.io running under docker i Ubuntu

I did restart after adding mobile_app

2020-01-02 01:18:40 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for hacs which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2020-01-02 01:18:40 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for zigbee2mqtt_networkmap which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.
2020-01-02 01:19:04 ERROR (MainThread) [hacs] You have maykar/compact-custom-header installed with HACS this repository has been blacklisted, please consider removing it.

Those are the logs, doesnt say anything about app.

Do you have an older version of android? It might be related to the issue below?

Nope, Pixel 2XL with latest update

What android OS are you using?

i am using a custom ROM (/e/) without Google Play services (which means in many cases apps that require Play services and GCM don’t work or some features don’t work).
I get the same error when trying to login to HA for the first time after installation ,but if i terminate the app and restart, it does log me in.

(the only issue I face is that it does not add default mobile device_tracker - working on resolving this at the moment).

Hi,

I have the same problem, I’m using MicroG instead of Gapps and mobile_app integration is not working.
I can confirm that after killing the android app and starting it again, the app is working but there is no mobile_app integration in HA.

It would be nice to have an app which does not relay on Gapps, since the first sentence on home-assistant.io is:

Awaken your home

Open source home automation that puts local control and privacy first…

2 Likes

I was able to register my device by disabling
Microg-> google cloud messageing -> advanced (3dot menu) -> Confirm new apps

My device get registered and shows up in HA but its not updating the GPS location nor receiving notifications via notfify

Error in the log says:

Log Details (ERROR)

Tue Feb 04 2020 09:44:55 GMT+1100 (Australian Eastern Daylight Time)

Internal server error, please try again later: That is not a valid FCM token

I ended up using GPSLogger for location tracking. No solution yet for push notifications

do you have an google account added to microg?
I enabled confirm new apps in microg, but the HA app is not able to register to HA.

Despite I have google account added to microG, google cloud messaging enabled and confirm new apps disabled, phone is not registered or integrated.

[quote=“hollladiewaldfee, post:7, topic:158896”]
It would be nice to have an app which does not relay on Gapps
[/quote]Exactly. If not this thread, I would not suspect that the issue is with too much dependance on google services…

1 Like

actually in my case I had to ‘Disable’ the Confirm new Apps option (not enable).

the device not registering may be a micro G issue. Though that doesn’t take away the dependence of HA on Google services, since in my case even after registering it doesn’t work.

to trouble shoot microG, can you download ‘Push Notification Tester’ app and see if it registers to GCM and receives push notification?

Also, does the microG Self test display all options as ‘checked’ or not?

Got it registered after adding mobile_app: to the config (had default_config: from the beginning), and clearing (again) HA app. One of this two done the job.

Unfortunately, as you’ve previously stated, push notifications does not work. I’ve ended up installing HassKit to get the notifications working. Other apps such as Ariela might work fine as well.

in the self test not all are checked,
Play Store installed, is not, I have aurora store which is not seen by Microg, but I don’t think is a problem.
Storage permissions are also missing and can’t be fixed, I granted all requested permissions in the microg app setting

I’m also using microG and noticed tracking didnt work. I tried clearing appdata and loggin in again, after which i countered the same “unable to register application” error. Thanks for the tip, forcing the application to close did work.

But still looking for a way to track location…

try to install google maps for tracking…but u probably need to make sure you have google services too.

I just updated my android app and now everything works \o/ I got an popup asking for permission for location access, the integration is added, and i finally got battery/location/wifi sensors!

I face the same issue with microG. Is there a way to solve it?
Thanks.

Same here. The previously mentioned methods don’t work for me. Too bad that there isn’t a proper F-Droid edition for the companion app :frowning:

2 Likes

You should find »Libre Assistant« in the Grobox Repository:

https://grobox.de/fdroid/

3 Likes