Unable to remotely connect to Home Assistant with the new iOS app (1.5)

Tags: #<Tag:0x00007f7c6c48d128>

Hello @rocky! I have the same issue on my iOS App. But I didn’t understand what you did with the port 443. Can you help me? Thanks!

I had this issue too (v1.5 App) a few weeks ago when I changed over to SSL. It was rather bizarre as all I needed to do was to change the config entry in the HA iOS App from http://blah to https://blah. Worked fine on my iOS iPAD, but when I did this on my iOS iPhone it failed to connect and complained about the shared token. I reset the config in the app, and manually entered the data back in and still no luck. What did work, and its rather bizarre too, was I went to Safari and did https://blah just to make sure that it could connect to HA (and it did). I copied the URL from Safari, and Pasted it into the iPhone HA App’s config entry and it worked…can’t explain it…it just somehow worked.

Unfortunately this isn’t working for me =(

Got same issue, was always working fine before 95.x but after upgrade and my config got corrupted, it is not working anymore.

via inside lan, no issue
via mobile phone on 4g working
via IOS app on 4g not working
reset of IOS app not working

finally after removing IOS app and reinstall it worked again. looks like some saved credential issues which is not cleared after IOS app reset…

1 Like

Same issue here after installing DuckDNS. Everything worked, but the app.

Deleting the app and re-installing helped.


This worked for me as well.
The url in safari was something like https://xxx.duckdns.org/auth/authorize/… followed by a huge string of url parameters. Pasted that to the iOS app and got to the login screen. When I go back to my settings in the iOS app it strangely just displays my normal duckdns address that was not working previously, but now I am in.

Following this works perfectly. After setting Remote access using Duck DNS (Good guide here: https://www.youtube.com/watch?v=VUTPAoB27iQ) and successfully connecting to the home page in Safari through https:sitename.duckdns.org:8123 it redirects to a longer authorization url and login page. Copying that URL (https:sitename.duckdns.org/authorize etc)…and pasting that long string worked. I tried other combinations and that failed. The OP seemed to make it also work by forwarding Port 443 (HTTPS) to 8123 which also worked in my case too.

Hi Guys,

I recently installed HA on a ubuntu VM running on a Hyper-v server. So far so good :wink:
I installed the HA app on my iPhone and managed to connect to the HA server when i was @ home (internal ip). I am now trying to make it so that i can connect to my HA server using the ios when i am not at home (external/remote access), and this is were the problems start.

I have domain name registred with an external (EU) registrar and i made a forward from there to my home (static) ip. On my local router i made a port forward from external port 8123 to internal port 8123 which points to the local ip from the HA server.
As soon as i open up a browser and i browse to http://ha.domainname.nl:8123/ i can get a connection to my Dashboard.
When i enter this into the app i get the error “Shared.TokenManager.TokenError error1.” like stated by other users.
I tried every solution that worked for other users but i kepe getting the same error. I tried opening the URL from my safari browser on my iPhone, and i get connected. I tried to copy the long URL (stated by Dobby) into the app but I keep getting the error. For some strange reason forwarding port 443 to my internal ip with port 8123 won’t work (as in, it wont let me connect trough web).

Anyone have any other suggestions?

Thanks in advance!

I managed to fix the problem.

what i needed to do was open http://ha.domainname.nl:8123/ in my safari browser on the iPhone, log in and paste the URL it gives you into the app.

the way i read the other solution was just visit http://ha.domainname.nl:8123/ in the safari browser on the phone an paste the URL it generates. Since this did not work i tried login in and copy past the URL it gave me then, and voila we have connection.

Hope this will help someone some day :slight_smile:

1 Like

I had the same problem and the solution that helped for me was very simple: just append a slash / at the end of the url.
From
https://MyKeyHere.ui.nabu.casa
To
https://mykeyhere.ui.nabu.casa/

Cheers

1 Like

I just ran into this issue as well, but I was able to resolve it. It case anyone else sees this:

I’m using duckdns as well as the Nginx Proxy Manager that is basically taking my traffic from https://hass.mydomain.duckdns.org and passing it to http://192.168.1.X:8123. It works totally fine in any browser and brings me to the hass login page, but adding into the app was not working and giving me the same error OP was getting.

To resolve:

  1. Delete the app and reinstall.
  2. copy your duckdns link- in my case it was: https://hass.mydomain.duckdns.org NO slash, no port as nginx already knows it’s forwarding :443 traffic to :8123. Your case may be different.
  3. Paste into the ‘URL’ input in the app in the configuration area, and press Done. Do nothing else here.
  4. You will be brought to the login page and everything works perfectly.

I hope so too. I am going to try it now… :crazy_face::crazy_face:

I’m having this same issue. Unable to login to the mobile (iOS) app or via safari on my mobile. I uninstalled the app, reinstalled and when I click done it says “Initializing” but nothing happens.

Same issue here. Was working perfectly on my old iPhone, but I upgraded to iPhone 11 Pro and I cannot get app to reconnect. Still working perfectly on wife’s phone. I’ve tried everything, including deleting the app. Help!

Ran into the same issue today with the mobile app. I had everything working fine with DuckDNS but recently purchased my own domain and wanted to move over to that.

Accessing from the web browswer worked fine with https://mydomain.org:8123 but I would get the “Shared.TokenManager.TokenError error 1” error message. The only thing that worked for me was deleting the app and reinstalling it.

Once I did that I used https://mydomain.org:8123 and was taken straight to the log in page.

This is all a bit odd and I have found the iOS Companion app all a bit odd. The way it creates senors and multiple. The way notifications or location tracking won’t work and have to go thru hoops. That said, I think all or none of the above fixes work. Well they work but something is going on. I tried the Safari route and paste that URL in and the login page then came up. But then backed out and changed it back to the standard URL:8123 and it was still working. SO not sure what is being backed into Safari or something that is saving the token or something else or the fact that you just went to the site with Safari and some token/cert/key is now on the phone and since the app is using Safari it just now works for now.

Anyway I digress. What are people doing with the internal URL or don’t they anymore?

Thanks.

JR

My iphone automatically updated my app in background.
Now i am unable to login, it says that the component mobile_upp is not loaded.
I checked my config file, i have ios: , discovery: , mobile_app: but no login.

Then diggind the net i found a post where someone explained how to remove ios integration and clean the files in .storage folder but also in this case the login was not successful.

I tried to delete the db file, restarted HA several times.

nothing it wont’t work. I am concerned, as an IT manager regression tests are the ABC to have a solid platform. Home assistant every update needs to start again with all the configuration files and integrations. Quite pissed off.

Thanks.

Home Assistant is still a work in progress which is why almost every release has breaking changes. The new iOS mobile app is hundreds of times better than the previous version with some new capabilities. As such, there are breaking changes. There is a document that describes how to upgrade from the old to the new integration. Specifically it addresses how to remove the previous iOS integration and add or transition to the new mobile app integration. And for future reference, deleting the database file is only useful in troubleshooting the recorder functionality of HA when an upgrade fails or the database gets corrupted.

https://companion.home-assistant.io/en/getting_started/migration

I can confirm it took me about 10 minutes to fix everything after the upgrade.

If you have mobile_app:, or better yet default_config:, in your configuration.yaml but it not loading you probably have Outdated dependencies. Please see the guide here