Unable to see "Friendly Name" in gui

I have 8 identical Athom smartplugs all configured with ESPHome. 2 are spares waiting to be installed - the other 6 are all in services having had the exact same install procedure for all of them (the only one I know). None have any “custom” adjustments - all just plain vanilla - right out of the box. All have been updated to the latest ESPHome routinely as it becomes available.

5 of the 6 in service plugs are identified by their respective friendly name, while the other is only identifiable by its full name. The friendly name is set in yaml just the same as all the others - but HA is just ignoring it for some unknown reason.

I have deleted and reinstalled the device - but it come back in just exactly the same. It all seems to be working correctly so there is no real panic - I just can’t understand why this one is different to all the others…

Here is the relevant yaml

substitutions:
  name: athom-smart-plug-v2-a786a9
  friendly_name: Office Heater
packages:
  Athom_Technology.Smart_Plug_V2: github://athom-tech/athom-configs/athom-smart-plug-v2.yaml
esphome:
  name: ${name}
  name_add_mac_suffix: false
  friendly_name: ${friendly_name}
api:
  encryption:
    key: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx


wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

As it happens the 8 plugs were bought in two sets of 4 several months apart. The one with the issue, is the first to be installed of the second set - for the sake of this discussion “5 of 8”. 6 of 8 was using its friendly name, but when I deleted 5 of 8 - 6 (now promoted to position 5) also lost its friendly name. When the original 5 of 8 was reinstalled, 6 of 8 took up its friendly name again.

I’m at a loss - but then ESPHome is still deep black magic for me anyway so being at a loss isn’t particularly surprising.

Anyone have any clues?

What do you mean precisely ? Did you remove it from Settings → Integrations → ESPHome ? as it’s the only way to be sure HA updates properly the name of the node. Even better, remove it from there, restart HA and then add it back (HA should autodetect it with its proper name). If still seeing old name, it’s an issue in the sketch or when you flash that you flash the wrong unit :wink:
I would strongly suggest also to create your own proper sketch instead of embedding the one from Athom github. Basically you copy/paste code of Athom github in your sketch and adapt it for your own needs/names…

Thanks Vincen - yes that is exactly what I did. Settings - Integrations - ESPHome - Delete - Reboot HA - Set Up newly detected device. It did not however have ESPHome ask to Adopt the new device, it just accepted it as part of the family right away - so it was clearly remembered somewhere.

Suggesting I create my own “sketch” (?) is assuming a degree of understanding I do not have. I’m only really using it as a power monitor and would not have a single clue how to change anything anyway. So it is all default - as they all are - which leaves open the original question -why is this one any different to all the others?

If it is indeed an issue in the “sketch” - then why did the issue transfer temporarily to a different node while this one was deleted?

IMHO no need to Reboot HA after device deleted - never doing that.

Just to be sure - all devices have unique name and friendly_name in config ?

Can You somehow illustrate this:

What You mean under ‘identified by …’ - how it shown in ESPHome dashboard or in HA integrations list or what else? Not sure I clearly understand.

Thank You.

I only just noticed while grabbing the screencap below, that 6of8 (the one which temporarily lost its friendly name while 5of8 was deleted), is now also shown by its full name in the ESPHome screen…

But when viewed from the Integrations screen…

5of8 is the only one to be missing its friendly name. I also noticed that the order of the relevant integrations is reversed for this particular device. The wifi listing in the FritzBox for 5of8 includes an alias that is a perfect match for the Friendly Name (intended to avoid confusion), and that is exactly the same for all the other smartplug devices as well.

When trying to reference the Office Heater smart plug in an automation, I have to reference the full name as below, because it is not found by its Friendly name, while all the others are…

Very interesting.
Can You open devices with issues and press pencil icon, to see like this:

Had heard about some tools to dig into HA registry, but unfortunately have no experience with.
BTW any time tried tracker integration, saw strange effects and avoiding them to use.
I would remove it to see what happens.

I’m sorry - but I have literally no idea what you mean by this… What integration are you suggesting I should delete?