Unable to Update Home Assistant OS - Stuck on OS 8.1

i tried do Update via the Gui…but there just happens nothing…
then i tried to Update via terminal

i typed the following

ha core update --version 2022.8.4

which returned in the Terminal with Command completed successfully but i`m still on OS 8.1…

Can someone pls help ?

Core update is not the same as a HassOS update , the command is wrong

can you help me with the right command ?

 ha os update --version 2022.8.4

The three dots icon in the Settings → System → Logs menu has options to view the host logs which may shed light on why the GUi update did not work.

Thx for helping me out…somthing seems to be wrong on my setup

have to clue what`s going on

Go to Settings → System → Network and set your DNS server to or

this didn`t help…i changed to and also tried it with - same error :frowning:

Something on your network is preventing you reaching github.

is there a way to do this by hand - via usb or so ?

Update from 8.1 to 8.4 break my instance Pi 3b. Think twice before update if the bug fix not for your device, and always backup first.

Getting the same error - did you manage to find a fix in the mean time?

sry - still on the old Version…didn`t figure it out how to solve this

I believe I was having the same issue. What ended up working for me was:

ha os update --version 8.4

I looked at the github release it was trying to download and it didn’t have the 2022 in the name.

Also didn’t work - but I assume a bigger issue behind the installation of newer versions - see my next comment.

Okay guys, I didn’t solve the issue yet however to make sure I’t not my current configuration/installations fault here is what I did.

I flashed a brand new SD card with the latest version from github 8.4 and tried to boot my raspberry pi 4 connected to a screen. It starts booting but after 5 seconds crashes (without visible error) and reboots again infinite times.

I took the same SD card and flashed version 7.6 and it boots up like a charm. Tried newer versions higher than 7.6 without success. Therefore I assume there is an issue with the newer versions not beeing supported by my hardware?