Uncaught thread exception from AlarmDecoder

I’m getting an unknown status for my alarm_control_panel.alarm_panel device, and I’m getting the following error in home-assistant.log after updating to core-2021.3.0:

2021-03-06 02:22:06 ERROR (Thread-3) [root] Uncaught thread exception
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/threading.py", line 932, in _bootstrap_inner
    self.run()
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/devices/base_device.py", line 148, in run
    self._device.read_line(timeout=self.READ_TIMEOUT)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/devices/serial_device.py", line 247, in read_line
    self.on_read(data=ret)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/event/event.py", line 84, in fire
    func(self.obj, *args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/decoder.py", line 1041, in _on_read
    self._handle_message(data)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/decoder.py", line 439, in _handle_message
    msg = self._handle_keypad_message(data)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/decoder.py", line 477, in _handle_keypad_message
    msg = Message(data)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/messages/panel_message.py", line 85, in __init__
    self._parse_message(data)
  File "/usr/local/lib/python3.8/site-packages/alarmdecoder/messages/panel_message.py", line 121, in _parse_message
    self.system_fault = int(self.bitfield[17], 16)
ValueError: invalid literal for int() with base 16: '-'

Any idea what’s going wrong?

I wish I did. I’m having the same problem.

@markdstjohn I solved this problem but upgrading the firmware on my ad2USB to v2.2a.8.8.

https://www.alarmdecoder.com/wiki/index.php/Firmware

1 Like

Thanks for the tip, Bob. This solved it for me as well and restored some functionality that hadn’t been working for quite a while.

1 Like

Thanks, updating the firmware solved the issue for me as well.

1 Like

Many thanks Bob, this fixed my issues too

1 Like