Universal Solar Inverter over Modbus RS485 / TCP custom_component (Growatt, Sofar, SolaX, Solis)

I tried built in ethernet again together with Inverter power cycle, and suddenly your plugin works again. I believe that I tried to restart the inverter many times before without any success :slight_smile:

I could immediately try to solve another problem - the one that also appeared before the communication between inverter and HA stopped working. I was not able to change SolaX Charger Use Mode, when I changed the mode, it returned to the previous value after couple of seconds. Now I tried to change the mode directly in Inverter’s menu and there was an error DSP-COMM failed. I searched this thread and found similar problems about 2 years ago. In my case, the inverter was in Idle mode and SolaX Battery Awaken button from your plugin fixed the issue - I can now do everything I need with SolaX and Home Assistant.

Thank you very much for your patience with me and all the work you do for us.

1 Like

Glad you are sorted now and back up and running.

Thanks for the information.

May I ask since when is debugging enabled in the integration? I believe this could be contributing to my recorder freezing issue during backups. Solved by reducing the interval of reading data from the device from 1s to 5s. The problem with the recorder is gone for now. (so far 2 days it’s fine. before that daily problem)

ADD: first occurrence of the problem 15.10.2022

Debugging was increased on the Beta versions of 0.7.0 to enable fault finding and ensure the Integration is behaving the same as the previous 0.6.x

You really are pushing the Inverter to it’s limit with 1s poll rate.
There is meant to be a 1s gap between instructions to the Inverter. I am getting away with 2s poll on my Inverter with built in ethernet. But 5s is a more recommended polling Interval.

Indeed, 1s is pushing it. As @wills106 explained, we currently generate a lot more debug info, but only during the first 5 polling cycles.
You could also change your logging level to INFO instead of DEBUG, but I would also recommend to continue to work with 5s polling cycles.

@Vodny86 Do you also own a Sofar Inverter as well as your SolaX Inverter? I just noticed this post you made. SofarSolar inverter integration - #64 by Vodny86

I’m looking to buy the wavshare device to use with my solax x1 gen 4.
Will I need to also buy a programmer for the wavshare device to set it up?

Also will this then show me real-time details from the inverter not every 5 mins like Solax cloud?

I’ve recently received my Home Assistant Yellow, so no more Virtual Machine. I’ve bought the RS485 to USB adapter and cut the end off an Ethernet cable, stripped back the twisted pairs and screwed them into the adapter.
Ethernet order:
Pin 1 = white + orange
Pin 2 = orange
Pin 3 = white + blue
Pin 4 = blue
Pin 5 = white + green
Pin 6 = Green
Pin 7 = white + brown
Pin 8 = brown

On the USB adapter I have 5 ports: A, B, GND, GND, 5v. I’ve plugged in:
Pin 4 (Blue) to A
Pin 5 (Blue + White) to B
Pin 6 Green to GND

Is this correct? Also how do I know which GND I should be plugging it in to?

Replying to this post: SolaX Inverter by Modbus (No Pocket WiFi) ( now a custom_component ) - #359 by wills106

@jaishkp The default poll for the Gen4 is 15s, 5s is possibly ok.
You don’t need a programmer, just the software (Windows only) to do the initial setup of the Waveshare.
Then you can use the WebUI for any additional setup.

@tom1502 I would have thought the GND on the USB device are connected together, so it shouldn’t matter.
Unless you have a really long cable run, you don’t normally need a GND connected.

1 Like

Thank you. This is my first time doing anything like this so just wanted to make sure! Really hoping that this works!

Thank you. How do you set it up with the windows software, is it by connecting to it by Ethernet? I looked on the wavshare website and they showed a programmer hence why I’m now confused.

Would just like to say thank you! It’s now all working perfectly and I have full access to everything!

One question I do have though, what is the difference between Total Energy and Total Yield?

1 Like

If you get the one displayed on the Wiki I believe the initial setup is done with the software connecting over Ethernet.

I don’t personally own a Waveshare.

1 Like

Hi Will, I’m new to HomeAssistant and Solax but thanks to your incredible work I’ve already got my SK-SU3700e + LG 6,5 kWh battery integrated and am able to control charging. Because I have flex-tariff I would like to be able to sell (at certain hours) more energy than I use in my house. I’ve gone through all menu’s and settings and am coming to the conclusion that the only way to do this is by manipulating the dry-contacts. Is this correct or can this be triggered in software as well? greetings Lars from The Netherlands (first message on this platform)

Have you tried the instructions in the Wiki?
I don’t have a Gen2 automation example yet, but you can manually follow along with the Wiki and see if Export works correctly. SolaX Gen2 & Gen3 Modes of operation · wills106/homeassistant-solax-modbus Wiki · GitHub

1 Like

Thought I would give a summary of what’s been changing in the Pre-release 0.7.0
The custom_component has gone through another code rewrite with the support of @infradom
This custom_component is starting to become a Universal Solar Inverter over Modbus Integration supporting multiple brands of Solar Inverter connecting over RS485 / TCP where supported.

As well as the long standing SolaX support there are varying levels of support for the following Inverters:

  • Qcells Q.VOLT HYB-G3-3P
  • Sofar Hybrid HYDxxKTL
  • Sofar Older PV & AC Battery storage ie ME3000SP
  • Solis Hybrid G5

These are in various states of completeness, so please log issues on GitHub with the required information.
This custom_component / Integration will undergo a name change at some point in the future to provide extra clarity it’s not just SolaX focused.

0.7.0 Beta 16 Pre-release

Due to the number of breaking changes in the 0.7.x code it is recommended to remove the Integration from the Integration page before updating, then re add the Integration.

Initial test to confirm new sensor formatting it correct.

If you try this version, please take a screenshot before and after to confirm if the sensors are still correct including the scaling.
Also report back on any debug info in the Log.

Beta 3 Changes:

Moved to plugin_ for Inverter’s
(Only SolaX working at the moment)

Beta 4 Changes:

Added plugin_ for Inverter’s to config flow
Minor changes to SolaX registers in plugin_solax.

Beta 6 Changes:

Improved plugin loading
Updated Sofar Hybrid registers
Added older Sofar PV, AC & Hybrid Registers

Beta 11 Changes:

Update selection options to Support HA 2022.11 #140
Pin pymodbus>=2.5.3", "pymodbus<=3.0.1 Hopefully resolve #154
Further work on Sofar registers.

Beta 14 Changes:

Fixed #174
Adjusted minimum value of number.solax_battery_minimum_capacity_grid_tied

Beta 15 Changes:

Added Solis Hybrid Registers (xxx-5G)

Beta 16 Changes:

Corrected manifest.json preventing Integration from showing in Integration Page.


Please help me with Modbus Integration. I own a Solax X3 Hybrid 8.0E (H3UE08), installed May 2021. I am currently connected via WiFi Pocked and using SolaX Power Integration in HA. I have 45 entities displayed, I think it’s not enough, for example I’m missing the “House consumption” entity that I need for my automation.
There is a question: how to get more (all) entities from the inventor, integration of Modbus in HA and connection via an Enternet or RS845 cable will help.
Sorry for the description of my problem, I’m a beginner.
Thank you very much for your willingness.

As you have a Gen3 Inverter you should just be able to connect via the built in Ethernet.
It’s behind the bottom cover.

You don’t need an RS485 - Ethernet adaptor.

The Pocket WiFi doesn’t expose Modbus, unless you use it in a very insecure way.

Thanks for the advice, yes I will. Will this connection load more entities (more than the current 45)?