Universal Solar Inverter over Modbus RS485 / TCP custom_component (Growatt, Sofar, SolaX, Solis)

On the new Hybrids you have an Ethernet port (RJ45) on the inverter Motherboard it’s self, this is under the front cover. As well as terminals and an RJ45 for RS485 (ModBus).

I am plugged directly into the Ethernet port on the motherboard.

There is also two USB ports, one for firmware upgrade and the other for PocketWiFi

Aah that explains a lot, I will look into it tomorrow.
I think my best bet is to make a request to the webserver an edit the request header so it thinks it’s getting a request from or something. That’s the most simple way I think. Nonetheless thank you for your help so far.


Did you find the extra inverter sensors?
I have included a pic of what to look for.

If some of the values look off ie voltage is 11.5v etc send a screen shot, then I can adjust the values.

Unfortunately I got a major problem with my system. Battery is not charging and in the inverter menu, in the Work mode setting there is message DSP-COMM failure. I tried to switch off everything, switch off grid supply but no help. The batteries flash green which indicates they are healthy. The BMS after starting shows green but changes to flashing red.

There are some coincidences which give fodder for wild speculations as to why this happened. First, I changed to hourly based grid tariff, do not see how that could be related, maybe grid was off for a moment? Second, I have Raspberry Pi with Wills software running connected to the inverter, that has been switched off and on multiple times, maybe some random wrong signal was sent to the inverter? But Wills software apparently works and collects data from the inverter.

Did you shut down your batteries as well when you powered down the inverter?

It might be worth double check all you wiring is secure while the Inverter and battery pack’s are off.
You have the CAN from the main BMS to inverter (Battery pack with the extra lump on top) then from each battery to battery you have your DC (Y-Plug) and also RS485 daisy chaining from one to the other.

Might be worth noting my BMS flashes red when it’s dark / inverter has gone to bed.

Sorry if I am teaching you to suck eggs, but you can sometimes overlook something in panic.

You are correct that the solax.yaml package only reads from the Inverter at the min, there is no function for it to write a value to the inverter.


I have just bought (Yesterday) a cheap USB - RS485 off Amazon so I can double check my package works fine over RS485 ModBus in case you have no luck with you PocketLAN. I can’t see why it wont work ok though.

Just so you know RS485 in theory can work up to 1200 meters! So you could perhaps run some CAT5 from your inverter to a convenient location to plug a USB - RS485 dongle into your server.

I’ll let you know how I get on over the next day or so.

I figured out a way to get the api that solax uses itself. I loaded up bluestacks on my pc and installed the solax app. From there i used wireshark to see the network activity and found the exact address from the solax api itself. then from hassio i utilized the REST platform to fetch the data. One big advantage is that i can see all the data even if the inverters are offline.

This is one of the datasets.


Thanks anyway for all the help, if you want to know the API url’s i can send them to you

Definitely pls send to me…

I did try switching on/off inverter, battery and both, cut of power supply but nothing helps. BMS and battery seems to be OK, When I switch on the BMS with pushbutton it goes to green like waiting for the inverter and then flashes red.

In which place are you going to connect the USB-RS485?

Are you getting the data over WLAN or LAN?

I am getting the data from the solax servers every 5 mins, so no hustle with cables etc.

I will send the url’s when I have access to my pc.

I understand you get data via WLAN. I do not have WLAN, only LAN cable. I saw some information that access by WLAN is not the same as by LAN so it may be your url’s are not working over LAN. Anyway, this has to be tested.

@Tim1739 so you are getting your solar data from the Soloar cloud as per:


I want to keep my setup local and not reliant on the cloud though.


Any joy getting your Solar setup back up and running?

Good question:). There was little activity in the last days but now I am in full quest to get the issue solved, constantly exchanging messages with support. What the support has established is that batteries are fully discharged and apparently due to this the communication between the BMS and inverter is not working, the inverter is stuck with the DSP-COMM failure message. What should be done is to return inverter to normal mode and charge batteries to restore operation. My speculation is that all this could be because the inverter was in Force Time Mode before and maybe they have not considered such possibility of events in their software. Advice I just got is to try to kickstart inverter by setting it to the ‘normal’ mode. For this there is required that solar panels produce some energy and that is another issue since we have very little sun and some snow cover, that may improve later this week. Another method is to connect DC source to the inverter but its voltage should be more than 200V and I do not have such thing at hand. I asked if disconnecting batteries totally from the inverter could restart it to normal mode but have not got answer yet.

You are the man!!! Please send :wink:

Tim, I saw something in the manual regarding DIP switches depending if you used Modbus or Ethernet or wifi… I read it today but cant find it now. So it could be that you just need to flip a switch to activate it.

Here is another guy that has found some use of his Solax Inverters and created some automations. https://community.openenergymonitor.org/t/solution-reading-solax-sk-su5000-e-inverters-sdm630v2-modbus-power-meters/8214/17

Might be worth sharing some knowledge and reuse what he has done and vice versa.

These are the basic url’s to fetch the data, hope this gets you somewhere.
The only thing you have to search for is your password-hash i got it with wireshark.

Note that the data fetch from a specific site can take up to 30 seconds depending on the server load at solax.

When running the wireshark, did you do anything special or was it showned in clear text in the results view? Or did you have to go into any specific packet and look?

A small guide if you have time would be appreciated.

What I have created is based off his work, the second line of my file quotes that.

# Using https://github.com/InfernoEmbedded/PowerScraper as a basis for the Modbus registers used on Solax Inverters.