Update check interval every 5 min? (core 2022.4.1 & supervisor 2022.03.5)

Hi,

Not sure if it is introduced since 2022.4.1 but was just looking in the supervisor log and it seems there is an update request every 5 min:

22-04-08 19:26:10 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
22-04-08 19:26:10 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/home-assistant/addons repository
22-04-08 19:26:10 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/hassio-addons/repository repository
22-04-08 19:26:10 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/thomasmauerer/hassio-addons repository
22-04-08 19:26:10 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/zigbee2mqtt/hassio-zigbee2mqtt repository
22-04-08 19:26:11 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:26:11 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:30:21 INFO (MainThread) [supervisor.homeassistant.api] Updated Home Assistant API token
22-04-08 19:31:14 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
22-04-08 19:31:14 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/zigbee2mqtt/hassio-zigbee2mqtt repository
22-04-08 19:31:14 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/hassio-addons/repository repository
22-04-08 19:31:14 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/thomasmauerer/hassio-addons repository
22-04-08 19:31:14 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/home-assistant/addons repository
22-04-08 19:31:15 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:31:15 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:36:18 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
22-04-08 19:36:18 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/hassio-addons/repository repository
22-04-08 19:36:18 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/zigbee2mqtt/hassio-zigbee2mqtt repository
22-04-08 19:36:18 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/thomasmauerer/hassio-addons repository
22-04-08 19:36:18 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/home-assistant/addons repository
22-04-08 19:36:19 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:36:19 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:41:22 INFO (MainThread) [supervisor.updater] Fetching update data from https://version.home-assistant.io/stable.json
22-04-08 19:41:22 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/home-assistant/addons repository
22-04-08 19:41:22 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/thomasmauerer/hassio-addons repository
22-04-08 19:41:22 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/hassio-addons/repository repository
22-04-08 19:41:22 INFO (MainThread) [supervisor.store.git] Update add-on https://github.com/zigbee2mqtt/hassio-zigbee2mqtt repository
22-04-08 19:41:23 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove
22-04-08 19:41:23 INFO (MainThread) [supervisor.store] Loading add-ons from store: 65 all - 0 new - 0 remove

Did I mis something or is this normal and/or configurable?
Thanks in advance.

Wouter

Well, now that you pointed it out, I see the same in my log too. Unfortunately I can’t tell if it was so even before or did the last update cause it, but it surely seems a bit reduntant to check for updates every 5 minutes…

I have the same question. I’m fairly certain this only started with 2022.4.

The release notes for 2022.4 say:

“The Home Assistant Supervisor (providing Core, OS, and add-on updates), WLED, Pi-hole, and Synology DSM integrations have implemented these brand new update entities in this release.”

So I assumed this new log behavior was due to the new update entities, but I would love to have confirmation that this (log behavior) is normal/expected.