Update from 0.89 to 0.90 - No Change in Version - Still 0.89

Hello all, today I updated my instance of Home Assistant, running on a FreeBSD jail (FreeNAS 11.2) and I updated from 0.89. I did the command “pip3 install --upgrade homeassistant” but afther the update, and everything apparently ok, I rebooted HA, and I still see version 0.89 in the info page!

What did I do wrong?
Thank You

Did you enter the virtual environment first?

If not you may not have to versions of HA running. One inside the VE and one outside.


I use Home Assistant on a JAIL… I don’t use virtual env… no need to do that in a Jail!

Thank You

Gotcha, you posted in the hassbian section so I assumed a venv install.

You are correct! I changed the section! Any one can help me understand way I update HA, it gives a success message! If I try to update again it says it’s in most recent versions, but in the UI still shows 0.89!

Thank you

I’ll take a couple guesses.

I wonder if its a web page cache thing. Normally pressing F5 will reload a web page but there have been a few times where I have to use Shift + F5 to actually see changes in HA.

Just curious, Did you stop homeassistant before you tried to upgrade? I’m not 100% sure if it even matters but might be worth a try.

Otherwise it really seems like your running two versions of HA.

Maybe you trying to run and update a version not in a virtualenv but is there anyway possible the HA you’re actually seeing is in a virtualenv. What does the System Health say?

You are correct this is not needed but I still think its a good idea. There’s no additional overhead when using a virtualenv. Curious as to why you would skip this? I found a few times it has made my life easier simply because I was using the virtualenv.

I solved it! That was the problem! I used your script to install and I when I used the update script it worked!

Thank you

1 Like