Update Homeassistant (SOLVED)

Hi guys,

I am using HA for a while now and I never had any issues with updating core or the OS, which is normally pretty easy via the UI.
However in my current version of HA I can’t find any possibility to update.
If I click on “settings” both updates (core and OS) are shown, but I can’t start the update from the notifications. There is simply no button or anything to start the update. I already tried different browsers or Apps.
Probably and hopefully a silly question - Sorry for that. :slight_smile:

core-version: core-2022.4.7 - OS: Home Assistant OS 7.6

BR, Ben

Do you have admin privileges?
If you click on the update items on the settings menu you should get a pop-up with an option to install the update.

Anyway, I’ve automated the updates on my HA: Auto-update Home Assistant

Yes I have admin privileges. When I click on the update items in the settings menu I get a pop-up, but I do not have an option to start the update.

Try hitting refresh in your browser.

1 Like

Another idea would be to update via commandline. Install the ssh addon and run the following command to update:

ha core update --version 2022.6.7

Thanks for the help guys. It finally worked. As easy as it sounds Petes hint was the solution. After refreshing the browser I had to login again. Now I have the option to update.
Clearing the browser cache would probably have worked as well.

Thanks Mike as well. That would have been Option B. :wink:

1 Like