Update not available for built in addons

I has come to my attention that my built in addons stopped flagging available updates. I noticed that I stuck on ESPHome 2021.11.1 while its several releases behind. Same with Nodered I’m on 10.1.1 where v10.4.0 is the latest. Is there a way to trigger updates for these? Or better restore update check?. Also I would rather wish to avoid reinstall as I have quite a lot of nodes in there.

EDIT: I tried to “check for updates” button in the add-on store but no new updates appearing.

See below my info page.

System Health

version core-2022.2.0
installation_type Home Assistant OS
dev false
hassio true
docker true
user root
virtualenv false
python_version 3.9.7
os_name Linux
os_version 5.10.63-v7
arch armv7l
timezone Europe/London
Home Assistant Community Store
GitHub API ok
Github API Calls Remaining 5000
Installed Version 1.19.3
Stage startup
Available Repositories 968
Downloaded Repositories 28
Home Assistant Cloud
logged_in false
can_reach_cert_server ok
can_reach_cloud_auth ok
can_reach_cloud ok
Home Assistant Supervisor
host_os Home Assistant OS 7.2
update_channel stable
supervisor_version supervisor-2022.01.1
docker_version 20.10.9
disk_total 27.7 GB
disk_used 12.7 GB
healthy true
supported true
board rpi2
supervisor_api ok
version_api ok
installed_addons File editor (5.3.3), TasmoAdmin (0.16.0), Mosquitto broker (6.0.1), Duck DNS (1.14.0), deCONZ (6.11.1), Samba share (9.5.1), Home Assistant Google Drive Backup (0.105.2), FTP (4.3.0), Node-RED (10.1.1), Log Viewer (0.12.1), ESPHome (2021.11.1), NGINX Home Assistant SSL proxy (3.1.1), Google Assistant SDK (2.5.0)
Lovelace
dashboards 1
resources 22
views 9
mode storage
Spotify
api_endpoint_reachable ok

Log after restarting:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

Add-on: ESPHome
ESPHome add-on for intelligently managing all your ESP8266/ESP32 devices

Add-on version: 2021.11.1
You are running the latest version of this add-on.
System: Home Assistant OS 7.2 (armv7 / raspberrypi2)
Home Assistant Core: 2022.2.0
Home Assistant Supervisor: 2022.01.1

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 20-nginx.sh: executing…
[cont-init.d] 20-nginx.sh: exited 0.
[cont-init.d] 30-dirs.sh: executing…
[cont-init.d] 30-dirs.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[00:07:27] INFO: Waiting for dashboard to come up…
[00:07:31] INFO: Starting ESPHome dashboard…
2022-02-03 00:07:38,349 INFO Starting dashboard web server on unix socket /var/run/esphome.sock and configuration dir /config/esphome…
[00:07:38] INFO: Starting NGINX…

Make sure the add-ons appear in colour - if they are greyed out there is a problem with the repository.

Ok I fixed it by adding the below repository. Now I can see updates.

https://github.com/hassio-addons/repository

2 Likes

You saved my day