Updated ZwaveJS to MQTT to 0.9.1 - Zooz ZEN30 double switches no longer working

Inovellis, GE/Honeywell outdoor modules, old Levition appliance modules all work. The only two not working are two Zooz double switches. Status “Alive,” Interview Stage, “Complete” for both, but they’re non-responsive and show as unavailable in the UI. Re-interviewing doesn’t fix them.

EDIT: Here’s a log from re-interviewing.

2021-04-02 06:48:47.810 INFO ZWAVE: Calling api refreshInfo with args: [ 53, [length]: 1 ]
2021-04-02 06:48:47.870 INFO ZWAVE: Success zwave api call refreshInfo { success: true, message: 'Success zwave api call', result: undefined }
2021-04-02 06:48:48.500 INFO ZWAVE: Node 53: value added: 114-0-manufacturerId => 634
2021-04-02 06:48:48.501 INFO ZWAVE: Node 53: value added: 114-0-productType => 40960
2021-04-02 06:48:48.502 INFO ZWAVE: Node 53: value added: 114-0-productId => 40968
2021-04-02 06:48:48.760 INFO ZWAVE: Node 53: value added: 134-0-libraryType => 3
2021-04-02 06:48:48.766 INFO ZWAVE: Node 53: value added: 134-0-protocolVersion => 5.3
2021-04-02 06:48:48.768 INFO ZWAVE: Node 53: value added: 134-0-firmwareVersions => 1.5
2021-04-02 06:48:52.529 INFO ZWAVE: Node 53: value added: 134-0-sdkVersion => 6.71.3
2021-04-02 06:48:52.535 INFO ZWAVE: Node 53: value added: 134-0-applicationFrameworkAPIVersion => 3.1.1
2021-04-02 06:48:52.537 INFO ZWAVE: Node 53: value added: 134-0-applicationFrameworkBuildNumber => 52445
2021-04-02 06:48:52.537 INFO ZWAVE: Node 53: value added: 134-0-hostInterfaceVersion => unused
2021-04-02 06:48:52.538 INFO ZWAVE: Node 53: value added: 134-0-hostInterfaceBuildNumber => 0
2021-04-02 06:48:52.539 INFO ZWAVE: Node 53: value added: 134-0-zWaveProtocolVersion => 5.3.0
2021-04-02 06:48:52.539 INFO ZWAVE: Node 53: value added: 134-0-zWaveProtocolBuildNumber => 43
2021-04-02 06:48:52.540 INFO ZWAVE: Node 53: value added: 134-0-applicationVersion => 1.5.1
2021-04-02 06:48:52.541 INFO ZWAVE: Node 53: value added: 134-0-applicationBuildNumber => 52445
2021-04-02 06:49:57.832 INFO ZWAVE: Node 53: value added: 37-1-currentValue => false
2021-04-02 06:49:57.833 INFO ZWAVE: Node 53: value added: 37-1-targetValue => undefined
2021-04-02 06:49:57.941 INFO ZWAVE: Node 53: value updated: 37-1-currentValue false => false
2021-04-02 06:50:00.855 INFO ZWAVE: Node 53: value updated: 37-1-currentValue false => false

I upgraded to Zwave-JS 2Mqtt 0.9.1 yesterday and my Door/Window sensors and Tilt Sensors from Vision Security (Monoprice) no longer report on/off (open/close) in the binary sensor. Just remains stuck at either on or off. These were all working fine prior to upgrading.

Is the only way to go back to a prior version through a snapshot restore? Not seeing an option to downgrade via the add-on.

1 Like

Same almost story here , the zen 30 relay part doesnt work, all other switches work fine. The dimmer part works ok though.
I have opened another thread about it

In case you still have the same issue after even 0.1.16 update, what i did is exclude the switches then re-include them and they work without issues. Hope it helps

Did you get this solved by any chance, @photo64? I have exact the same issue with 3 (out of 8) of my Fibaro FGK101 Door/Window sensors. Everything works, except for the binary sensors that seems to be stuck in either open or close. Already spend quite some time resetting, removing, re-adding, re-interviewing etc, but didn’t solve the issue for me.

I have not. It first occurred on 0.9.1 (zwave-js2mqtt) so I eventually rolled back to 0.8.0 and it still happens for my Vision Security door sensors (monoprice). I went out and got 2 ZHA door sensors since this was impacting a largely used area. I noticed that 0.9.1 isn’t even available to upgrade to now. Hoping it gets resolved soon so I can repurpose the monoprice door sensors elsewhere. On a side note, I have monoprice tilt sensors for my garage doors. They weren’t working on 0.9.1 but have started to work again under 0.8.0. Unsure why these came back but the door sensors didn’t. Everything worked perfectly prior to originally upgrading to 0.9.1

**Edit -> I stand corrected, for kicks I went and looked again at my door sensors and they are working again under 0.8.0. Must have just started because they weren’t reporting on/off just a day ago but seem to be working now. If you can roll back that might help or wait to see if today’s HA release has any impact.

Thanks! I’ll hope the next release will fix it. Currently on 0.9.1 and stupid enough no backup of previous version available.

Edit: Update to 0.11.0 didn’t work for me. Even did a zwave stick (Aeontec gen5) reset and started from scratch reinstalling the zwavejs integration, but can’t get those sensors back to work. Temperature and battery status work, but open/close is still stuck. Did another reset and as test installed Z-Wave (deprecated), added the sensors that stopped working in JS and worked like a charm. Wonder if you experience the same behaviour @photo64

I have not moved to 0.11.0 yet, a little hesitant until I see no issues. I was on OZW prior to zwave-js but have not gone back. Have you also updated HA to today’s release?

0.11.0 also did not solve the problem for me and my 2 fibaro universal sensors. They are still not updating their status.
Everything else works fine

Oh my! So I’m not alone :slight_smile: my Fibaro Door/Window sensor FGK101 (v2.5) also stopped working in ZWaveJS2MQTT - the last working version was 0.9.0. I have also neocoolcam door/window sensor which are working fine :slight_smile:
I did create bug report: Fibaro Window/Door (FGK101) sensor doesnt work anymore (binary sensor) · Issue #48790 · home-assistant/core (github.com)

1 Like

Awesome, thanks for bug reporting this. Strangest thing for me is that I have 5 still working with the same firmware and 3 with this problem. I hope they’ll find a solution soon

I’m having the same problem with my older Vision Security Motion Sensor (ZP3102). Worked fine on 0.8.1. Doesn’t work on the latest 0.11.0.

In any case, I found a quick workaround. Search for the device under “Devices” in HA. I found 1 disabled entity called “sensor.X_basic”, where X is the sensor name. Click on the entity and enable it. In a few minutes it gets enabled. The sensor shows “0.0” when there’s no motion and “255.0” when motion is detected. Either change your automations to trigger based on these values, or create a binary sensor Template that is true when “sensor.X_basic” is “255.0” , like this:

binary_sensor:
  - platform: template
    sensors:
      my_motion_sensor:
        friendly_name: "My Motion Sensor" 
        value_template: '{{ is_state("sensor.X_basic", "255.0") }}'
        device_class: motion

So far it’s working reliably. Also temperature reporting seems to work fine like before. HTH.

1 Like

The workaround for the FGK101 I found is removing the DS18B20 temperature sensors from the FGK101 modules with this issue and re-add them.

This looks like a good work-around for the motion sensors. Did anyone find a way to make the ZEN30 dimmers work?

Mine eventually came back, but I’ve since restored a snapshot and they’ve gone back to being unavailable.

I’m using zwaveJS (not MQTT) V0.1.17 and I have two issues that seem related to the thread above since zwavejs2mqtt’s code base uses zwaveJS as I understand it:

  1. ZP3102 by Vision Security (PIR sold by Monoprice) - Motion is no longer a bool since the update, it is identified as a “basic” sensor and returns the value 0 or 255.
  2. ZD2102 by Vision Security (Door / Window sold by Monoprice) - has not changed from on state since updating to V0.1.17.
  3. ZL7101 by Vision Security (Plug-In Dimmer Module sold under multiple names) - on/ off no longer responsive under groups. I suspect this has to do with the dimmer control now showing up as Supported color modes brightness
  4. Zen30 by Zooz (in-wall Relay & Dimmer) - Dimmer shows as unavailable. Seems to be a similar issue to what was reported above.

Mine are now working. I did a full network heal and, in the case of the ZEN30 combo switches, did a re-interview. There appear to be some new entities in the latest update and it looks like a couple of my old entities are deprecated, including an Inovelli fan entity from the light/fan switch and an entity which represented both switches on one of my ZEN30 devices. I don’t know enough about this to say why, but I now have an entity in the “fan” domain for the Inovelli switch that wasn’t there before.

I bumped ZwaveJS to V0.1.18 ZwaveJS (without MQTT) doesn’t seem to offer a heal or re-interview functionality. I power cycled the ZEN30 to see if it would trigger a re-interview. You can see my original kitchen light dimmer unavailable, the breakfast table relay which still works and now a Dimmer & Dry Contact Relay which doesn’t appear to do anything.

I was able to find the basic sensor and enable it but mine is mine is not a sensor it’s a number

number.garage_door_tilt_sensor_basic

I assume you did not see the same?

zwavejs2mqtt: 6.5.2
zwave-js: 8.11.6