Upgrading to 2023.5.0 Broke Elk M1 Integration!

A bug was reported indicating upgrading to Home Assistant 2023.5.0 breaks access to the Elk M1:

I am trying to implement the workaround (use elk://hostname instead of elks://hostname), but the logs show it’s still trying to connect to elks://hostname. I restarted my system with the same result.

Within the configuraton.yaml file, I have:

elkm1:

  • host: elk://192.168.1.50
    username: !secret elkm1_username
    password: !secret elkm1_password
    auto_configure: true

Any ideas?

Things I have tried:

  1. I restored a previous backup, but it still didn’t work (even after hard reboot)
  2. I deleted the integration, then readded it. This fixed the issue but broke all of my automation because it used an “elkm1” prefix for all entitiy ids.

Okay, here is how I fixed this issue:

  1. removed the Elk-M1 entry in the configuration.yaml file
  2. removed the entire Elk-M1 integration which removed all of the devices and enities
  3. re-added the Elk-M1 integration via the integration web page using the non-secure port
  4. edit the YAML file for automations and dashboard and added the prefix “elkm1_” to all old Elk M1 entity references

It appears the upgrade to 2023.05.0 upgrades files that are not part of the configuration backup.

Nowhere in the release notes do I see any references to updates to OpenSSL.

Mine is broken as well.

[elkm1_lib.connection] Error connecting to ElkM1 ([SSL: NO_PROTOCOLS_AVAILABLE] no protocols available (_ssl.c:1002)).

I will have to try removing and adding back the integration as you suggested unless someone else has a better idea.

Thanks

I did not have the 2023.05.0 problem. But what you describe here is a current problem with 2023.06.
See: Elk M1 no longer integrating after upgrade to Core 2023.6 · Issue #94198 · home-assistant/core · GitHub