USB Issue on HAOS

Weird issue, wondering if anyone can help diagnose or provide an explanation for this.
Running HAOS 2024.6.2 on x86 box, with a few add-ons.
Shut down the host so I could put a smart plug to monitor the energy usage of the box.
Upon bringing the box back up, noticed none of my Zigbee devices were working (Conbee II stick, using deCONZ on a 10ft extension cable).
Add on keeps trying to restart, but failing with “ERROR: Device ‘/dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2212600-if00’ does not exist in deCONZ (core_deconz).”
In HA Hardware section, the device is no longer appearing. My Zwave stick is still showing and functioning, but not the Conbee II.
Tried: Restarting HA, no change. Reboot host, no change. Restored from backup, no change. Shut down host and remove smart plug, no change. Unplug, replug USB Conbee II, no change.
Resolution: What actually worked, was removing the USB Conbee II and putting it into a different port (was previously in USB 2.0 port, moved to USB 3.0 port). Upon reboot, everything came back and the device ID remained the same in the Hardware section (which is also in the deCONZ config add-on).

It kinda seems like the USB port just died out of the blue? Could the addition of the smart plug caused this somehow?
Host box Home Assistant command line now shows the following when a monitor is plugged in:
ha> [ 490.560466] usb 2-1.5: device not accepting address 11, error -32

This is actually a common diagnostic and fix for dongle issues, moving it to another USB port. I would say, for me, it’s the second thing I attempt when I had an issue like that when I was on an rPi.

I don’t think your USB port died, it’s just forcing HA to look to a different USB port allowed it to reconfigure itself, whereas the old USB port it likely assumed all previous settings were still applicable. Generally I have been able to just move it back to the original after it’s working and it works again.

It can also be helpful to used a powered USB hub instead of going right to the port, in case the power supply or the port itself is not pushing enough power for reliable communications. Since moving to extensions and powered USB hubs as a rule (even on a fully powered bare metal system) I’ve had far fewer issues.

Just googling around on this particular error, and it appears to be rather common. The kernel tries to read the device in that USB port but can’t … but seems the problem is hardware related, and possible power related meaning not enough current from the x86 on that port(s) to power the USB device(s). So yeah it could be plugging in another USB device is causing to much power draw.