WADWAZ-1 GoControl Door Sensor

Hi,

I recently purchased the GoControl WMK01-21 Kit with that contained Z Wave Door Sensors and 1 PIR sensor. The PIR sensor paired up without any problems, but I’m having the hardest time with the WADWAZ-1 Door/Window sensors that came with the kit. I can pair the door sensors without a problem. With the back plate still off from the pairing process I can trigger the sensors without any problems. As soon as I place the back plate on the sensor the red light blinks and the sensor loses contact the HA. I’ve tried to, heal the zwave network, restart HA, pull the battery on the sensor all without solving the problem. I’ve even added and removed the node 5+ times. Has anyone else experienced this? If so how did you solve the problem?

I have the same ones, it takes a long time for them to come back up after a reboot. Does the device show in the zwave panel with a state of cacheload? I think for me it has taken up to like 20 minutes for them to start working.

Yes, they show as cacheload. I’ve let them sit overnight next to the zwave hub (Aeotec USB) and still no change.

they still may be working. have you tried to trigger them?

I have several battery powered sensors that stay pretty much permanently in the CacheLoad state and they work fine.

They don’t appear to be working. I’m doing a tail of the OZW_Log.txt while trying to trip the sensor and nothing for the node (Node 27) shows in the log.

if you open or close the door do any of the entities in the states page of HA change values?

No, I’m not seeing any value changes when the sensor is opened or close. This is what the states page shows:

binary_sensor.linear_wadwaz1_doorwindow_sensor_sensor_21 state: on
sensor.linear_wadwaz1_doorwindow_sensor_alarm_level_18 state: 255
sensor.linear_wadwaz1_doorwindow_sensor_alarm_type_18 state: 7
sensor.linear_wadwaz1_doorwindow_sensor_sourcenodeid_20 state: 0

I don’t see any change in the binary sensor for the three I have. I only see changes for the alarm level sensors. Do you see that value changing? I had to write template binary sensors for each door sensor to check if the alarm level is greater than 0.

i don’t think all of those entities are from the same device. all of the entities from the same device should end in the same number. that’s how they get created when you add them to HA through the add node service.

how many sensors do you have paired right now? at least three?

No I dont see a change in the alarm level sensor. When you have a change on yours, do you see a log entry in the OZW_Log.txt saying the value has changed from 255 to 0?

Right now I have 4 sensors pair successfully. 3 AC powered, and 1 Battery powered. Over the course of me troubleshooting, i’ve been unpairing the nodes and repairing, but new node IDs are still assigned. Since I originally made this post I’m now at node 31 for the sensor question. Here’s the output of the status screen for node 31. Maybe I need to unpair all sensors and factory reset my zwave USB?

binary_sensor.linear_wadwaz1_doorwindow_sensor_sensor_21
status: on
node_id: 31
value_id: 72057594563002368
value_instance: 1
value_index: 0
friendly_name: Linear WADWAZ-1 Door/Window Sensor Sensor

sensor.linear_wadwaz1_doorwindow_sensor_alarm_level_18
status: 255
friendly_name: Linear WADWAZ-1 Door/Window Sensor Alarm Level
unit_of_measurement:
node_id: 31
value_id: 72057594564067345
value_instance: 1
value_index: 1

sensor.linear_wadwaz1_doorwindow_sensor_alarm_type_18
status: 7
friendly_name: Linear WADWAZ-1 Door/Window Sensor Alarm Type
unit_of_measurement:
node_id: 31
value_id: 72057594564067329
value_instance: 1
value_index: 0

sensor.linear_wadwaz1_doorwindow_sensor_burglar_20
status: 3
friendly_name: Linear WADWAZ-1 Door/Window Sensor Burglar
unit_of_measurement:
node_id: 31
value_id: 72057594564067489
value_instance: 1
value_index: 10

sensor.linear_wadwaz1_doorwindow_sensor_sourcenodeid_20
status: 0
friendly_name: Linear WADWAZ-1 Door/Window Sensor SourceNodeId
unit_of_measurement:
node_id: 31
value_id: 72057594564067361
value_instance: 1
value_index: 2

zwave.linear_wadwaz1_doorwindow_sensor_21
status: initializing
lastResponseRTT: 0
receivedDups: 0
is_failed: false
friendly_name: Linear WADWAZ-1 Door/Window Sensor
node_name: Linear WADWAZ-1 Door/Window Sensor
wake_up_interval: 3600
sentTS: 2019-01-19 23:28:39:588
averageRequestRTT: 0
is_info_received: true
is_ready: false
sentCnt: 1
node_id: 31
is_zwave_plus: false
sentFailed: 1
lastRequestRTT: 0
averageResponseRTT: 0
manufacturer_name: Linear
is_awake: false
max_baud_rate: 40000
product_name: WADWAZ-1 Door/Window Sensor
receivedTS: 2019-01-19 23:27:28:381
retries: 0
query_stage: CacheLoad
battery_level: 83
receivedUnsolicited: 0
receivedCnt: 0
capabilities: routing,beaming

That might be the best thing at this point. However…

with the “new” device/entity registry implementation the devices might not go away even then.

maybe you should:

  • remove all nodes thru the zwave control panel in HA. restart HA. verify the nodes are removed from HA by looking in the zwave control panel.
  • check the entity registry and device registry to see if those devices were removed from there
  • if not, stop HA, rename/delete those files then restart HA, those files should be regenerated with the current system information.
  • factory reset you z wave controller. factory reset all the sensors.
  • add one of the door sensors.
  • at that point you should have one sensor and all of it’s associated entities listed in the states page.
  • check to see if it is working and troubleshoot further from that point with only one device to minimize confusion.

Thank you for all the advice. I’ll give your suggestions a try and report back with results.