Wake_on_lan switch 'update interval'

please add update interval for wake_on_lan
my logbook keep say false positive notification that my pc turn on and off almost time

It would also be nice if the number of send packages (currently 1) or timeout (currently 1s) can be configured to reduce false detection.