WakeOnLan YAML configuration - cannot add switch to dashboard

Hi! I’m a newbie to the YAML config, and I wanted to get some help regarding adding a WoL switch.

I read up this guide, and with its help I wrote up this script:

# Wake on Lan
wake_on_lan:

switch:
  - platform: wake_on_lan
    name: "home-pc-wol"
    mac: xx:xx:xx:xx:xx:xx
    broadcast_address: x.x.x.255
    host: x.x.x.252
    turn_off:
      service: shell_command.turn_off_home_pc

shell_command:
  turn_off_home_pc: "ssh [email protected] sudo shutdown 0"

And my question is… Now what?
There are no YAML errors, everything seems okay… except when I try to add this switch to my dashboard, I see nothing. Can’t find it anywhere. Searched in the settings through devices, entities, services - it’s not there.

Am I missing something? Thanks in advance for any help!

Did you restart HA ?

I’ve done the “quick reload” - I’ve read somewhere that should be enough after modifying YAML.
So, I fully restarted HA now, and it’s there.

Thank you, and sorry for making a post for such a simple fix :smiley:

Any changes to configuration.yaml needs a full restart

1 Like