Weather Underground

I tried the sample from

sensor:

  • platform: wunderground
    api_key: your_api_key Here of course i got my api
    monitored_conditions:
    • weather_1d_metric
    • weather_1n_metric
    • weather_2d_metric
    • weather_2n_metric
    • weather_3d_metric
    • weather_3n_metric
    • weather_4d_metric
    • weather_4n_metric

group:
daily_forecast:
name: Daily Forecast
entities:
- sensor.pws_weather_1d_metric
- sensor.pws_weather_1n_metric
- sensor.pws_weather_2d_metric
- sensor.pws_weather_2n_metric
- sensor.pws_weather_3d_metric
- sensor.pws_weather_3n_metric
- sensor.pws_weather_4d_metric
- sensor.pws_weather_4n_metric

I only get errors:

Testing configuration at /volume1/homeassistant ERROR:homeassistant.util.yaml:YAML file /volume1/homeassistant/configuration.yaml contains duplicate key “sensor”. Check lines 58 and 72. Exception ignored in: <bound method BaseEventLoop.del of <_UnixSelectorEventLoop running=False closed=True debug=False>> Traceback (most recent call last): File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/base_events.py”, line 381, in del File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/unix_events.py”, line 58, in close File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/unix_events.py”, line 139, in remove_signal_handler File “/volume1/@appstore/py3k/usr/local/lib/python3.5/signal.py”, line 47, in signal TypeError: signal handler must be signal.SIG_IGN, signal.SIG_DFL, or a callable object

Your problem is with your configuration yaml.

Can you post it with personal data redacted and use the code tags to troubleshoot?

homeassistant:
name: Home
latitude: 52.294
longitude: 4.9184
elevation: 0
unit_system: metric
time_zone: Europe/Amsterdam
customize: !include customize.yaml

introduction:

frontend:

config:

http:
016/10/25/explaining-the-updater/
updater:
discovery:

conversation:

history:

logbook:

map:

sun:

sensor:

  • platform: yr

tts:

  • platform: google

cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

sensor:

  • platform: wunderground
    api_key: not displayed here
    monitored_conditions:
    • weather_1d_metric
    • weather_1n_metric
    • weather_2d_metric
    • weather_2n_metric
    • weather_3d_metric
    • weather_3n_metric
    • weather_4d_metric
    • weather_4n_metric

group:
daily_forecast:
name: Daily Forecast
entities:
- sensor.pws_weather_1d_metric
- sensor.pws_weather_1n_metric
- sensor.pws_weather_2d_metric
- sensor.pws_weather_2n_metric
- sensor.pws_weather_3d_metric
- sensor.pws_weather_3n_metric
- sensor.pws_weather_4d_metric
- sensor.pws_weather_4n_metric

You need to use proper formatting using the code blocks.

Your problem is that you have sensor: listed twice

1 Like

Unfortunately, yaml is very formatting specific. So in order to really diagnose this you need to paste the code in as code. In the reply box, click the button that looks like this: </>

And then paste your code in.

But looking at your code it looks like you have a random URL in the config, right above Updater.

introduction:

frontend:

config:

updater:

discovery:

conversation:

history:

logbook:

map:

sun:

sensor:

  • platform: yr

tts:

  • platform: google

cloud:

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

sensor:

  • platform: wunderground
    api_key: not displayed here
    monitored_conditions:
    • weather_1d_metric
    • weather_1n_metric
    • weather_2d_metric
    • weather_2n_metric
    • weather_3d_metric
    • weather_3n_metric
    • weather_4d_metric
    • weather_4n_metric

group:
daily_forecast:
name: Daily Forecast
entities:
- sensor.pws_weather_1d_metric
- sensor.pws_weather_1n_metric
- sensor.pws_weather_2d_metric
- sensor.pws_weather_2n_metric
- sensor.pws_weather_3d_metric
- sensor.pws_weather_3n_metric
- sensor.pws_weather_4d_metric
- sensor.pws_weather_4n_metric

indent preformatted text by 4 spaces

You’re not making it us easy helping you. :wink:

How difficult is it to properly format the code you post? Just use </> when posting…

If you copy your configuration code into the reply window you then need to select all of it and then click on the code block button ( </> ) at the top of the editor window.

it will show us your code in the same format as you have it in your configuration file so we can help you find syntax errors.

But what @flamingm0e said above is correct. You have two places where you have sensor:. you can only have it once.

move all of your sensor: stuff together under one sensor: entry.

Take a look at a working sample here. Multiple sensor tags and also
I don’t see a station ID in your config. That will be your next problem

sensor:
  - platform: yr

  - platform: wunderground
    api_key: your_api_key
    monitored_conditions:
      - weather_1d_metric
      - weather_1n_metric
      - weather_2d_metric
      - weather_2n_metric
      - weather_3d_metric
      - weather_3n_metric
      - weather_4d_metric
      - weather_4n_metric

Dear J. assuncao,

i dit Exactly what oembob said:
Unfortunately, yaml is very formatting specific. So in order to really diagnose this you need to paste the code in as code. In the reply box, click the button that looks like this: </>

Not one post of yours is formatted correctly.

highlight ALL the code and hit the </> button

Thanks i shall look at it. But i first go to the initial state of HA, my first configuration.yaml file i got when i installed HA as i directly got an error on discovery:
so here the minimal configuration right at first start (no weather) and for some reason i must first copy configuration.yaml to my computer (Mac) and then open it with textwrangler before i can copy it to this venster.

homeassistant:
  name: Home
  temperature_unit: C
  latitude: 52.294600000000003
  longitude: 4.9119000000000002
  time_zone: Europe/Amsterdam

discovery:

frontend:

conversation:

history:

logbook:

You should explain your setup. You should NOT have to copy the file to your local computer first. You have a setup issue somewhere.

Yes that have i done. Place tekst into venster and then select all the codetext and then push </>

First as i have a normal Synology so no Docker and no additive programms like Hassio does. For DS214play there is only one version of Homeassistant and its the old version and that version does not have some editor. Ergo the only options left in menu are: States, Log, History and log out,
So i have to edit the configs with File station from Synology. And so i also have set the privileges of the /homeassistant map to 777 because otherwise i could not edit and save any config file.

You can edit those files directly over the SMB/Samba share. You don’t have to copy them to your computer first.