Websocket_api loaded by default? (not using default: config)

Having carefully selected (and removed several ‘default’) integrations/components, I now see the websocket_api in the newly available components list of loaded components under developer-tools/info

since I never needed it, and don’t care about the connected_clients sensor based on this, I had disabled it in the past. Especially since it was suspected to cause many errors in the logs, and maybe even resource hogs.

How come this is now loaded after all, while I have this in the config:

# https://www.home-assistant.io/components/websocket_api/


#  - platform: websocket_api
   #creates sensor.connected_clients

Not using default: in configuration.yaml, I like to be very precise in what integrations are loaded.
please have a look what might cause this appearance…

Because the front end uses it for communication. You are just not specifically using it in any of your customizations.

ok, but why then would we have the option for using


at all in the config? If it is already loaded no matter what.

btw, what does is do in the front-end? alway understood this to have been a backend component…

That’s only if you want to use websocket_api for something in your customizations. For example I don’t use it explicitly but my system still does for communication between components. It’s there by default. Also I didn’t say it resides in the front end only that the front end uses it.

what are you saying here? which customizations?

nor did I :wink: I merely asked what it does in the front-end.

Customization as described in this snippet from the Oct 12, 2018 0.80 release announcement:

Next up is a new way to get data into Home Assistant: webhooks. With the introduction of auth and with the introduction of long-lived access tokens, we realized that it’s still annoying to have to give full HA access to an app just to get a piece of information in Home Assistant. So with webhooks we can generate unique URLs that are inprobable to guess, and data delivered to the webhook will only go to the designated automation or component. This feature is available for component developers to integrate, or for users via the new automation webhook trigger.

If you would like to know more I suggest you dig into the Dev Docs at https://developers.home-assistant.io/