Wemo switch turn on as script doesn't wok

Folks,
try to switch on a wemo switch which works in the GUI via script. What I tried is:
#############################################

TEE anschalten

#############################################
TEE_On:
alias: “Turn on Tee switch”
sequence:
- service: homeassistant.turn_on
data:
entity_id: switch.tee
#############################################

TEE ausschalten

#############################################
TEE_On:
alias: “Turn on Tee switch”
sequence:
- service: homeassistant.turn_off
data:
entity_id: switch.tee

What is wrong here?

When you post YAML, be sure to preformat it so that we can spot errors. Indentation is significant,

Something to try: Lower-case the script name. I’ve seen cases where people run into case issues with how things work internally in HASS

tee_on:
  alias: "Turn on Tee switch"
  sequence:
    - service: homeassistant.turn_off
      entity_id: switch.tee

Thanks. I will gibe a try