Wemos D1 mini with mitsubishi2mqtt

I have an mitsubishi AC unit (MSZ) and i want to controll it from HA.
I saw a guide on how to flash a Wemos D1 mini with mitsubishi2mqtt, i followed all the steps but i have the below issue.
I flash the D1, the wifi AP with name HVAC_xxxxx appears, i click to connect to it and the connection takes some time and then it does not redirect me to the configuration page.
Neither when i try to navigate with the browser to i can connect.

Has anyone the same issue?
Any ideas what might be the problem?


When connected can you ping the interface of the D1 Mini from the device you’ve connected to it’s WiFi AP?

Perhaps try a different device to connect to the AP?

I used the cmd to ping the ip but i am getting the below.
Screenshot 2021-09-10 100817

I tried as well to connect with an android phone but without any sucess.

Try flashing with a different package and see if you can connect to it.

Also, did you set the correct board in the IDE your using when you flashed it?

I have tried several packages (all the below) but none of them works.

The board that i am using is the below

An the board that i have selected in the Arduino IDE is the “LOLIN(Wemos) D1 R2 & mini”

Here’s the link which walks you through some basic checks with the WiFi module:


If working with the IDE is a bit new, I’d suggest you check out the ESPHome integration for the Mitsubishi Heatpump here;

Flashing with ESPHome would also be an easy way to test if the board is working correctly.

Be aware ESPHome sometimes detects the boards as generic ESP01, but you can specify the correct board in the YAML.

Thanks alot for you help.
I will check the provided links and will give you my feedback.