Wemos disconnecting on prepare for first use

Hi guys,

I’ve just connected a Wemos D1 mini pro to my pc using a micro usb cable. It’s connecting just fine when using https://web.esphome.io/;
image
image

But when I click “Prepare for first use”, I’m either hit with an “cannot initialize :eyes:” or the following “Terminal disconnected: TypeError: Failed to execute ‘pipeThrough’ on ‘ReadableStream’: Cannot pipe a locked stream”.

I’ve tried to look around for the error messages multiple times, but I can’t seem to find anything around the Google lands…

Any tips?

Had similar issues with multiple D1 mini (non pro), I turned to ft232 flashing in the end as I was not willing to be more patient :slight_smile:
Edit: after that initial one, I could continue to flash OTA

In my case it was an app (Cura) which was stealing the serial port.

Not with me, just to provinde mor infoi…got the same screen above and then clicked install fro… and then waiting (for ever), tried other d1…same. The usb port I used is the same that I used for the ft232 afterwards, it is/was not the port with me imo

It eventually worked out for me, making sure the drivers were installed, started compiling from my computer rather than HASS to speed things along.

I got it working as well with a FT232 and regular cabling, including gnd<>d3 … no need to install locally.
But still not able to get it working via usb direct…did not try anylonger as ft232 did the trick