What is this error?

Got it last night.

16-11-18 01:46:17 homeassistant.core: BusHandler:Exception doing job
Traceback (most recent call last):
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/core.py", line 1210, in job_handler
    func(*args)
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/updater.py", line 74, in <lambda>
    hass, lambda _: check_newest_version(hass, huuid),
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/updater.py", line 82, in check_newest_version
    newest, releasenotes = get_newest_version(huuid)
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/homeassistant/components/updater.py", line 128, in get_newest_version
    return (res['version'], res['release-notes'])
TypeError: 'NoneType' object is not subscriptable

Running 0.32.4

3 Likes

Looks like updater ran into a problem when checking the version. As long as you don’t keep seeing it, it may have been a transient issue.

1 Like

I just checked the log and it has happened again.

1 Like

Yeah, it’s been cropping up on mine lately too - and I haven’t been getting update notifications lately either.

1 Like

Hi,

I’m getting the same error and no update notifications since upgrading beyond 0.31 and the new updater component.