Which is the best method to add Sonoff switches (configured via EWlink)

Hello all,

which is the best method to add Sonoff switches (original firmware, configured via EWlink) ?
If i use eWeLink Smart Home, when i try to switch on a light, it does not.
when using eWelink’s app from my tablet, switches on and off normally.

I use this with around 30 Sonoff devices, original firmware. Works flawlessly and coexist with Ewelink app fine.

1 Like

thank you very much, switched to this.

1 Like

HA says “GitHub - AlexxIT/SonoffLAN: Control Sonoff Devices with eWeLink (original) firmware over LAN and/or Cloud from Home Assistant is not a valid repository”

Did I copy the address wrong?

Yes.

Even easier, install SonoffLAN through HACS.

I just did this a couple of days ago following this tutorial.

Hi everyone, I am new with HA and HACS too.
I tried many times to install HACS without succed, the problem rise when I try to activate HACS.
A screen pop-up with 2 steps:

  1. Open Sign in to GitHub · GitHub
  2. Paste the following key to authorize HACS:
    After follow steps the screen stays there without progress, eventhought the Github has granted access
    Any clue if this is a router constrain? or HA config?
    thanks in advance

PROBLEM SOLVED!!! I found a post in Github, sorry for this post