WIFI configuration error (both GUI and CLI)

Hello all
i’m struggling in setting up wifi connection on rpi4. (below all the specs)

My wifi network is configured for WPA-PSK so WEP is only a sort of check here.

Anyway, with WPA-PSK, there is always an error about the password (and i already triple checked that).
Tried with WEP, and here the strange thing is that there is an error telling that ‘open’ isn’t a valid value but i’m on WEP radio button (see screenshot) as if the whole options were ‘shifted’.

With the CLI about same results, with nmcli exits with this error:
Error: Connection activation failed: (7) Secrets were required, but not provided.

Tried out almost everything i’ve found on the internet but no way to sorting this out…

Anyone on this?

TIA

SYSINFO:
version: core-2021.12.10
installation_type: Home Assistant OS
dev: false
hassio: true
docker: true
user: root
virtualenv: false
python_version: 3.9.7
os_name: Linux
os_version: 5.10.63-v8
arch: aarch64


GitHub API: ok
Github API Calls Remaining: 4739
Installed Version: 1.20.0
Stage: running
host_os: Home Assistant OS 7.2
update_channel: stable
supervisor_version: supervisor-2022.01.0
docker_version: 20.10.9