Home Assistant Community

Wifi Setup Help!

#1

I have Homeassistant installed on a external hard drive and a Pi 3 Model B V1.2 booting off of the hard drive. When I try to start it up though it keeps looking for ethernet. I configured a file named “my-network” inside of CONFIG/network and that didn’t fix it. It still is looking for ethernet. Any ideas? I am stuck!

#2

Note- I am not an expert, and my reply is likely to be wrong.
How did you install HomeAssistant? Are you using an image file, or installed on Raspian?
How do you know it’s looking for Ethernet? Is there an error message or log message?

I am most puzzled by your file “my-network” and the folder “CONFIG/network”. Where are you seeing these instructions?

#3

Hi - I was installing via these instructions: https://www.home-assistant.io/hassio/installation/

See the “wifi” section.

The way I know it is looking for Ethernet is bc when it boots is says something like booting… “ethernet not found”

#4

So, you installed from an image file.
I never used step three since my “mission critical” devices are all on Ethernet.
So, show us the WiFi configuration text file.
Also, have you ever had this Pi on WiFi using Raspian, or did you go straight to Hassio?

#5

I just went straight to Hassio.

I used this config, but replaced my SSID and PW.

[connection]
id=hassos-network
uuid=72111c67-4a5d-4d5c-925e-f8ee26efb3c3
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=MY_SSID

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=MY_WLAN_SECRET_KEY

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

#6

Your config looks right. Does the boot stop when it errors on Ethernet or can you see the IP on the router?

#7

I have the same issue on fresh install…

Tried setting a static IP on the network configuration file, with or without I have the same issue.

DHCP is working fine, also when I tried setting the static IP I made sure it was not reserved for any other device.

I tried several configurations on the network file from different people and also the one in the official how-to, it seems to be an image issue.
This is after a corrupted microSD on the same RPI 3B+ ( I got a new microSD ) , I get the “ethernet not found” error. However a microSD with Raspbian works on it this RPI 3B+ just fine.

I have tried flashing both 32 and 64 bit versions of Hassio on this microSD.

I also tried doing it with freshly baked microSD from Etcher on my RPI 3B (not the 3B+ but I get the same error).
I will try another microSD later on… I have made sure the microSD is working correctly it is a Kinston 16GB Class 10.

Wireless setup won’t work as well, I get the same error.

Could a microSD cause the “ethernet not found” issue?

#8

First, remember- I don’t use WiFi on my Hassio device.

I used to think that fixed IP on the device was the best solution, but wiser (probably not older) minds here convinced me to set the static IP through my Router. I arrogantly insisted that my Actiontech (FIOS) Router did not support Static IP addresses because I couldn’t find “static ip” or “fixed ip” anywhere in the manual. I finally found it under “Static Lease”. If you can get it working over DHCP, just make the IP static in the router and forget the mystery of IP configuration on the device. Or just use Ethernet.

Here are some of my notes from troubleshooting my Raspian WLAN0 problems. Important- I have tried none of these on Hassio.

I had a persistent problem in Raspian where WLAN0 was Not associated. The issue persisted on several RPI boards including two right out of the box. It turned out to be due to my WiFi password being in quotes. (Which in itself is a mystery because only one other person reported this problem). I removed the quotes from the password in /etc/wpa_supplicant.conf and the problem is gone. But since there is no wpa_supplicant.conf file in HassIo, you can’t test that.

From the command line, enter ifconfig. What does it show for WLAN0?

ls /sys/class/net/ will tell you if there is a wlan0 device present.

Have you tried setting a temporary IP, for example:
ifconfig eth0 192.168.1.126 netmask 255.255.255.0