Wink component local control

I just set up wink integration using the new directions using wink: only.
I then used the configurator to finish setting up… but how can i add local control? anytime i added additional configurations it wouldnt setup the intergration.

Hmmm, you should just be able to have the following in your config.

wink:
  local_control: true

Are you saying that doesn’t work?

i was actually asking if it would work! and if i can add it after the fact ( hoping i dont have to reauthorize)

O okay, yeah just added it and reboot. No need to run through the setup again.

you just tried it and it worked? thats great thank you

Well I am not using wink anymore, but I wrote the integration :grin: so unless something has changed that I wasn’t aware of it will work.

haha dang. well thank you for that. it does seem to have worked. im back up and running and not getting any errors that i can tell.

I’ve got 2 Wink Hubs (wink 1 type), one local and one remote. Just for giggles I tried adding the local_control: true thingie and; yes, everything appears to be still working just fine thank you very much…

(although when I unlock my door at the remote location, I do get this: Error sending local control request. Sending request online)
but I understand that is by design so…

i am now also gettting that error. well see if things continue to function so far it didnt turn off the lights at the end of the script… wierd

also this hub is at my dads house so im not sure if hes on the latest sw with local enabled

Local control will only work if home assistant and the hub are on the same local network. Enabling it when that isn’t the case will actually make things slower. Basically it tries to send the request locally and once it times out it sends it online.

1 Like

was the ability to use exclude a custom PR? i tried adding and it didnt work
I dont need a couple things to come in from wink.

Yeah exclude wasn’t ever implemented officially

would it be easier to just remove them from wink and reload? or does the custom work well?

Not sure the custom component to exclude would work anymore. I don’t even remember when I worked on that, a lot has changed in HA since then. If you don’t need those items in Wink anymore the best thing to do would be to remove them from the account/hub and reload. If you still need them in Wink, but don’t want them to show up in the frontend just don’t add them to any views/remove them from the default views.

1 Like

With the current multiday Wink outage, I tried enabling local control. I was up late and my wife called me around midnight saying "will you fix the f’ing lights, they have turned on and woke me up 5 times tonight! So, I disabled local control and the problem went away.

I don’t understand why it happened. All that matters my WAF dropped significantly last night. :slight_smile:

1 Like

ive started getting this showing up 11k times. i think its related to wink and some device…

2019-05-04 23:48:25 WARNING (EndpointThread-Heartbeat-0) [urllib3.connectionpool] Retrying (Retry(total=0, connect=None, read=None, redirect=None, status=None)) after connection broken by 'ReadTimeoutError("HTTPSConnectionPool(host='ps.pndsn.com', port=443): Read timed out. (read timeout=10)")': /v2/presence/sub-key/sub-c-f7bf7f7e-0542-11e3-a5e8-02ee2ddab7fe/channel/5806c6cd3b416a5dc5f3b2814cdc04d275e766b7%7Clight_bulb-4039922%7Cuser-916753,aab985c1c10d8cf8a3c59ab51ba5a2c4e38d4558%7Clight_bulb-4039923%7Cuser-916753,a07988a15c509a683a6a18c4f82fd672d36980f0%7Cthermostat-416342%7Cuser-916753,aeaa0582708c96b603b7bde256200771d863aa59%7Clight_bulb-4039925%7Cuser-916753,b180fa8baaa4f743e929ee03e562bf8902a6ff82%7Clight_bulb-4039926%7Cuser-916753,5561d2bd6e85109cfbab3c0b55f6b6b57c673cb1%7Clight_bulb-4039937%7Cuser-916753,1011872e96ee96f38b71cc3fb40ae802d35f6cb7%7Clight_bulb-4118143%7Cuser-916753,11720df13c27d348e51ec14d76b1c5088cf0bb5a%7Cbinary_switch-814680%7Cuser-916753,78f9ce507b6005a55fa0d2d73df30d7ca054d77b%7Cbinary_switch-814683%7Cuser-916753,2d16c570fc19062c3f0a09974c2bd33e927d158c%7Cbinary_switch-882149%7Cuser-916753,57264b67963f1b4eb4cbcf8c5282946ac9568d3a%7Cbinary_switch-882160%7Cuser-916753,binary_switch-903747%7Ce1c04faddb2cdb7ad3c54808dd2d614a7c4768d8%7Cuser-916753,5fcf836f867b3633f7303c58fd0aa81e0790ef81%7Cbinary_switch-923269%7Cuser-916753,ff59adc774155765ea64272938c7a9ffd3a2cd8b%7Chub-903230%7Cuser-916753,508aa757a3567dcf3fc3947a51e9a38e11925dc7%7Chub-940728%7Cuser-916753,door_bell-80141%7Cf26deb683f30b998c0e46bd0da07895d56f7b43e%7Cuser-916753,aab1478e17cbf447c814312ac8f17b3c755442b6,1f72a436a85816c558e513380dd651218e9b5478,6933291b02f0b768f832032145f6d0f89ddac247,69da94be35989ac7d61e66476363efcf29284c94,8180c81ceaf962aa4bf00d7260d4a51f41fb17d9,6abd1ecdfcd16259a03144316d88b0c3e0d7d01e,73034b2241d7bd4f2576d90bf75722d66b38afcf%7Csensor_pod-605994%7Cuser-916753/heartbeat?heartbeat=300&pnsdk=PubNub-Python%2F4.1.0&uuid=80edff8e-7c82-4b3a-ba4f-57a07115ae16
2019-05-04 23:48:25 ERROR (EndpointThread-Subscribe-0) [pubnub] Exception in subscribe loop: HTTP Client Error (400): {"message":"Invalid Subscribe Key","error":true,"service":"Access Manager","status":400}

I’ve enabled local control for wink hub in the configuration.yaml file. My understanding is that this would avoid the need to have internet access. I tested it by disabling internet to my wifi router. With the internet off I can still connect to homeassistant.lcoal:8123 from my laptop so I know HA on Raspberry Pi is still connected the internal wifi network. However, when I tried to turn a light on, I got an error message. It looks like still still sending request online. Am I missing some configuration step? Thanks for any help. I tried to go through the online documentation, but I am reading some conflicting accounts.

Copy to clipboard

HTTPSConnectionPool(host='api.wink.com', port=443): Max retries exceeded with url: /light_bulbs/1428200 (Caused by NewConnectionError('<urllib3.connection.HTTPSConnection object at 0xb04f4a50>: Failed to establish a new connection: [Errno -3] Try again'))
1:02:13 PM – Home Assistant WebSocket API (ERROR)

Error sending local control request. Sending request online
1:02:08 PM – components/wink/light.py (ERROR)

Not sure why this isn’t working, but enabling local control doesn’t prevent the need for internet access, and it also isn’t going to prevent you from needing to pay Wink for their new subscription service.