WLED: fixing entity name

Hey guys,

I’ve just started using WLED with HA and have some problem for basic turn on/off WLED using the dashboard.
I’ve a WLED called wled_rainbow with 2 saved presets.

  • 1 = no segment define
  • 2 = 5 segments

Starting WLED with preset 1, I can see the following entity in HA:

  • light.wled_rainbow
  • switch.wled_rainbow_nightlight

Looks good, so I create a sample switch on/off on lovelace for “light.wled_rainbow” and everything is working fine.

Now, I switch to preset 2 and I have these entities:

  • light.wled_rainbow
  • switch.wled_rainbow_nightlight
  • light.wled_rainbow_master
  • light.wled_rainbow_segment_1
  • light.wled_rainbow_segment_2
  • light.wled_rainbow_segment_3
  • light.wled_rainbow_segment_4
  • light.wled_rainbow_segment_5

If I use lovelace to switch on/off “light.wled_rainbow”, it affect ONLY the first segment of the strip led.

So, I can’t use “light.wled_rainbow_master” on preset 1, because it doesn’t exist and “light.wled_rainbow” doesn’t seem to do the job.

How do you guys handle this ? Is it possible to see and control entity “light.wled_rainbow_master” even if no segment are define ?

Thank you guys in advance for any help you can provide me with!

EDIT: can be usefull

  • WLED v0.11.1 “Mirai” build 2101130
  • HA 2021.1.4

Hey

i added one extra LED in the wled config.
If you got 120, your config is 121.
in every preset i have a segment with led 121.
so i got the light.wled_master every time.

also i set under WLED setting LED Preferences

Apply preset 1 (or any preset you choose)

for getting the master again after reboot.

Regards
Jens

1 Like