X-custom_components

I recently installed HACS to my Docker/home-assistant installation. I copied the HACS folder into the custom_components folder. Home Assistant (HA) started up well and Hacs was displayed and seemed to work displayed options to select. I did no other changes at that time.
Today I tried to start HA and got

This site can’t be reached

192.168.1.191 took too long to respond.

I went to the home-assistant Docker folder and saw that the custom _components folder had been renamed to x-custom_components. I renamed it back to custom _components, but that did not help.
Here are the items in the home-assistant folder:
image

custom_components folder
image

hacs folder
image

What could have caused this and how do I fix it?

I don’t see anything called x-custom_components unless that is after you already renamed it.

if that’s the case then everything seems at first glance to be OK there.

I’m not sure what needs fixed.

Assuming that means you still can’t start HA successfully then what are the contents of the home-assistant.log file?

The log file shows many repeats of the following:

2020-02-18 12:07:22 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/config/custom_components/hacs/hacsbase/init.py”, line 302, in recuring_tasks_installed
await self.factory.execute()
File “/config/custom_components/hacs/hacsbase/task_factory.py”, line 24, in execute
await asyncio.gather(*self.tasks)
RuntimeError: cannot reuse already awaited coroutine

remove the hacs entry from your config or remove it from the integrations section and see if that helps.

I tried it both ways, but no help.

What’s weird is that I had previously moved hacs out of home-assistant folder into config and today it was in both places.

I have no idea what that means.

Can you clarify?

I got the following request from Finity
remove the hacs entry from your config or remove it from the integrations section and see if that helps

My response:
After your suggestion, I looked and found HACS in both folders. I was surprised since when I moved it to one I also deleted from the other. But it does not seem to work in either location… Should I delete Hacs in all locations and start over?

remove HACS from anywhere and everywhere you have it in your config.

restart.

See where you end up.

In order to restart, I have to start. That was the problem to begin with. Is it possible that the HA is still running but I can’t access it? Is there an external command that I can use to stop it in this Windows Docker installation?

Any other suggestions?

Do you have a way to edit your configuration files without having access to HA? do you have a samba share or something like that?

The original installation did not include a Samba share that I know of.

No, you have to set it up yourself. Along with SSH.

So you have no way of making any changes to your system at all right now?

Do you have known good system backups?

If the answer is no to both of those then I think your only option is to start over.

It appears that I can access my Synology Docker Home Assistant folder and edit files via Visual Studio. Will that be sufficient?

it should be.

did you edit your config to remove all traces of HACS from your config?

look in both your configuration.yaml file and in the files stored in the .storage directory and remove entries related to HACS.

in the .storage folder there should (might…) be several files named “hacs.xxx”. you can remove those. and in the “core.config_entries”, “core.entity_registry” there should be entries in there to remove.

You will need to make sure that HA isn’t running before editing those .storage files. And make sure you keep the correct json structure of those files when you edit them. I recommend making a backup of those files somewhere before editing/deleting them just in case something goes horribly wrong.

Once you remove all references to HACS in those files the start your HA again. I’ll leave it up to you to figure out how you need to do that. Maybe restart the entire VM?

I have removed all instances of HACS and restarted HA. I dont get the original issue in the log but the following appears:
[homeassistant.config_entries] Config entry for wled not ready yet. Retrying in 80 seconds.

I believe this is related to a WLED programmed NodeMCU which has failed and has been removed and discarded. Is there a way to remove it from the system and avoid this issue?

So do you now have your frontend UI back?

Sorry, I meant to say that it still does not get to the UI.

ok, then restart your HA again and wait a minute or two and then post the contents of your home-assistant.log file from your config directory.

2020-02-23 09:43:30 WARNING (MainThread) [homeassistant.config_entries] Config entry for wled not ready yet. Retrying in 5 seconds.
2020-02-23 09:43:39 WARNING (MainThread) [homeassistant.config_entries] Config entry for wled not ready yet. Retrying in 10 seconds.
2020-02-23 09:43:53 WARNING (MainThread) [homeassistant.config_entries] Config entry for wled not ready yet. Retrying in 20 seconds.
2020-02-23 09:44:17 WARNING (MainThread) [homeassistant.config_entries] Config entry for wled not ready yet. Retrying in 40 seconds.

if those are the only log entries then it doesn’t make any sense why your UI won’t load. That’s a warning, not an error and I’ve never seen an error cause issues loading the UI.

But just to be sure then you need to do the same thing for WLED as you did for HACS and find all entries for WLED in your config files and remove them and restart again.