Xiaomi Aqara Error

Tags: #<Tag:0x00007f7399b19388> #<Tag:0x00007f7399b19270>

Hello everybody

Until a while ago, I had my Xiaomi Aqara integrated in my HA with a water leak sensor. That had worked too. But suddenly I get an error message:

Invalid config for [xiaomi_aqara]: length of value must be at most 16 for dictionary value @ data[‘xiaomi_aqara’][‘gateways’][0][‘key’]. Got ‘e3ab8cd52d44e4ef04d27c4e7416b015’. (See /config/configuration.yaml, line 68).

I’ve tried removing it and adding it from scratch. Including on the Mi Home app.

As I understand the error, the HA can no longer cope with a token that is longer than 16 characters. However, I have other integrations, with 32 characters tokens.

Thats the code in the configuration.yaml:

xiaomi_aqara:
  discovery_retry: 5
  gateways:
    - key: e3ab8cd52d44e4ef04d27c4e7416b015

Maybe someone gave me a hint what I could try?

Thank you for that and have a nice Sunday everyone.

BR

My key is 16 characters long and given in the app. That’s strange if your key is longer. Did you get it like described here: https://www.domoticz.com/wiki/Xiaomi_Gateway_(Aqara)#Adding_the_Xiaomi_Gateway_to_Domoticz