Xiaomi component stopped working after getting ethernet connection

Greetings. Here is my another problem. I found, that HA does not work stable. It can reboot by itself. No logs, by history I see, that every part of HA just goes off and then on (sometimes it does not even reload)
That is why I decided to try ethernet instead of wi fi (and deleted 70% of my automation). I have changed system-connections file to this:

[connection]
id=my-ethernet
type=ethernet
interface-name=eth0
permissions=
secondaries=

[ethernet]
mac-address-blacklist=

[ipv4]
address1=192.168.1.127/24,192.168.1.1
dns=8.8.8.8;8.8.4.4;
dns-search=
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

And now I have this:

2018-09-08 17:54:04 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don't require it, remove the 'api_password' from your http config.
2018-09-08 17:54:25 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.
2018-09-08 17:54:43 WARNING (MainThread) [homeassistant.setup] Setup of xiaomi_aqara is taking over 10 seconds.
2018-09-08 17:54:58 ERROR (SyncWorker_12) [homeassistant.components.xiaomi_aqara] No gateway discovered
2018-09-08 17:54:58 ERROR (MainThread) [homeassistant.setup] Setup failed for xiaomi_aqara: Component failed to initialize.
2018-09-08 17:54:58 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity.py", line 313, in async_update_ha_state
    self.entity_id, state, attr, self.force_update, self._context)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/core.py", line 853, in async_set
    context)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/core.py", line 618, in __init__
    "Format should be <domain>.<object_id>").format(entity_id))
homeassistant.exceptions.InvalidEntityFormatError: Invalid entity id encountered: zone.. Format should be <domain>.<object_id>
2018-09-08 17:55:08 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting
2018-09-08 18:14:41 ERROR (MainThread) [homeassistant.core] Error doing job: Fatal error on transport TCPTransport (error status in uv_stream_t.read callback)
TimeoutError: [Errno 110] Operation timed out

Everything seems to work but the xiaomi. And yeah, it works via Mi app.
Need an advice from you

Tried some points from https://www.home-assistant.io/components/xiaomi_aqara/

  • Try to leave the MAC address mac: blank.
  • Try to set discovery_retry: 10 .
  • Try to disable and then enable LAN access.
  • Hard reset the gateway: Press the button of the gateway 30 seconds and start again from scratch.

Did not solve the issue. I tried to delete component from configuration.yaml, but nothing had changed.

You should post the relevant Xiaomi configuration as well. Is it possible you have both WiFi and Ethernet on?

Also you have some errors related to zones in your config. Might be best to resolve these first. Always use the config validation button after making changes.

I tried different xiaomi configurations (with mac, without, with ip, without, with “mac:”)
For now I have this:

xiaomi_aqara:
  discovery_retry: 10
  gateways:
    - key: 151774A1694E45F4

Look, I did not change anything here when it stopped working.
Answering yuor second question - no way. I ave shown my connection config. I double checked - can not access if ethernet is out of raspberry.
Next, issue with zones is an old one. I am trying to solve it too.
And I always tap config validation button before reboot.

Done with zones (I just renamed them from russian to english)

2018-09-08 22:11:15 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don't require it, remove the 'api_password' from your http config.
2018-09-08 22:11:37 WARNING (MainThread) [homeassistant.setup] Setup of config is taking over 10 seconds.
2018-09-08 22:11:38 WARNING (MainThread) [homeassistant.setup] Setup of xiaomi_aqara is taking over 10 seconds.
2018-09-08 22:12:18 ERROR (SyncWorker_4) [homeassistant.components.xiaomi_aqara] No gateway discovered
2018-09-08 22:12:18 ERROR (MainThread) [homeassistant.setup] Setup failed for xiaomi_aqara: Component failed to initialize.
2018-09-08 22:12:29 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting

Can you ping the xiaomi from your hass machine?

Not sure if it’s related to your Xiaomi problem, but I had a lot of issues going from wifi to Ethernet on hassos. I tried changing the network manager configuration file, but nothing I did could get it going. I ended up doing a snapshot, reinstalling hassos, and restoring my snapshot. Haven’t had any issues since.
If you have a spare micro sd, maybe try that?

Sorry, can not understand what does it mean
I do not see any way to communicate with xiaomi hub from HA

Seems like I have to buy one.
Tried to come back to wi fi and everything was just fine. Tried ethernet again and xiaomi is dead again

ssh into your home assistant machine and run

ping ipaddressofxiaomigateway