Xiaomi Mi - Philips ZeeRay Wi-Fi LED Smart Bulb support

Hello everyone,

I bought these lights:

I’m wondering if there is any support by Home Assistant.

Thanks in advance!

1 Like

Don’t know if you are still wondering since a year has passed, but I just tried to add these bulbs to my home assistant and it worked. You just have to use the xiaomi_miio integration and configure it like a Xiaomi Philllips Light. You can see how to set it up here: https://www.home-assistant.io/integrations/xiaomi_miio/#xiaomi-philips-light.

Thanks @mitram19 . It’s been another 2 years and I’m still here… :sweat_smile:

I followed the instructions for setting up the Xiaomi Philips bulb on Home Assistant via the Xiaomi Miio integration. The bulb was added, with an error message “This entity is no longer being provided by the xiaomi_miio integration. If the entity is no longer in use, delete it in settings”. Therefore, I couldn’t even switch it on and off in Home Assistant. I deleted and re-added the device but the problem persisted.

I also tried to set up my Mi Home Security Camera 360° via the Xiaomi Miio integration, but encountered a similar error. Did I miss anything that is not in the instructions? I am a noob to Home Assistant, and have just set it up running in a container on my Raspberry Pi 4. Any suggestion will be very much appreciated!

In my case, sometimes I also get the error message “This entity is no longer being provided by the xiaomi_miio integration", specially after updating home assistant to a new version. However, when I delete the device and readd it again it usually does the trick. I’m currently using the Xiaomi Miio integration and it is working:

Thanks very much for getting back to me. May I ask whether you are running your HA in a Docker container?

No, I’m running the home assistant operating system directly on a raspberry pi.

Ah, thanks - I suspect this may have something to do with Docker, as I saw some other users on GitHub reporting similar connectivity issues with other Xiaomi products via the Xiaomi Miio integration on containerised HA. However, I can control my Google Nest Hub from my containerised HA… Puzzled! :thinking:

Many thanks anyway for your info!