Xiaomi MIjia YEELOCK integration

What platform are you on? As on iOS it will log me out of the app if I try to open it with no network connection.

I’m using Android.

Any chance you can dump the apk file and upload it somewhere? :slight_smile:

If you have adb it should be as easy as:
adb pull /data/app/com.yeeloc.yisuobao.apk ./

Sure it is here: https://drive.google.com/open?id=1-2OBVmvykCgjlrFrbFHPpaGfu-gtsQ3M
Found it on a different location (/data/app/com.yeeloc.yisuobao-1F6mYwf8FmgTLMaPUyLrDA==/base.apk)

It seems to have been deleted, any chance you can try uploading it again? :slight_smile: Maybe somewhere that is not Google Drive if possible?

Also what else is in that folder? (/data/app/com.yeeloc.yisuobao-1F6mYwf8FmgTLMaPUyLrDA==)

Hi, I’m very interested to see some progress on this one, I have 5 of these set up to manage staff access to cupboards in a holiday rental.
I have contacted Yeeloc about adding some functionality to the application but I have not heard back from them.
Stuff like displaying the current lock status, locked or unlocked on the icon should be pretty easy to implement. Also I’d like to see the battery status permanently for each lock.

https://imtt.dd.qq.com/16891/4A99220FFA46F624769719961255A02C.apk?fsname=com.yeeloc.yisuobao_2.5.5_49.apk

This is the link from their official website, looks like it’s a slightly newer version to what’s on the app store.

Any progress? It looks like a fun lock, would love to use with HA.

I also am looking forward to this integration. :slightly_smiling_face:

I can verify that this is the case for me too. I tried perhaps 10 times, in order to see if this was just a temporary thing using buffered unlock codes, but it always worked. This was done in the span of two minutes though, so maybe there is a time out limit I’m not aware of.

Yeelock have finally updated this app. Battery percentage on the lock is now working and for some reason it now requests location access.

“for some reasons” I wonder what it could be :slight_smile:

But what about HomeAssistant? Btw do you know any other drawer lock that works with home assistant?

So I guess no luck from the advanced users/integrators? :slight_smile:

I’m keen on this integration also! Would be awesome having these locks integrated with home assistant!

Is there any new update? I expect something good.

Hi @cnrd @tom-x1,

The apk is proguard obfuscated.
However I found this link https://api.yeeloc.com/open-apidoc/ where the api is documented.
Also when I login in https://web.yeeloc.com/developer/index I could sign up in a developer section (still pending approval) which gave me access to SDK files: https://pan.yeeloc.com/s/fn5i3RwzCRGzRWd
Looks quite interesting.

2 Likes

Indeed. Good find. It’s all a bit over my head but it seems to me like there is a time limit when you request a temporary password, which would explain why it still worked when you use flight mode.

so any luck with this? what does developer section mean? SDK files can help us to have it working?
thanks.

I just took a look but got no result. Have you been able to unlock using this API?

Was thinking maybe we can use monkeyrunner https://developer.android.com/studio/test/monkeyrunner/MonkeyDevice and just use send commands directly to the app to lock and unlock