YET another take on an alarm system


#1401

Ok i can see that when calling https://hassip:8123/alarm directly makes the white borders show up and destroying the layout

I dont want to expose my entire hass on the alarm panel (kids), just /alarm (trusted network, saving login creds for some reason doesnt work)

So also it would be a good idea to have an option to hide the hass menu all together (Not only when armed), right?


#1402

How can I add this component

alarm_control_panel:
  - platform: arlo

if i already use the alarm_control_panel: !include alarm.yaml
for my bwalarm?

It just keeps saying I got duplicate key when I add the above to my config.


#1403

I am not. How come?


#1404

remove this from alarm.yaml:

alarm_control_panel:

And just leave it in configuration.yaml like so:

alarm_control_panel: !include alarm.yaml

Only have this in your alarm.yaml:

- platform: arlo

Edit: aah now i read it a second time, your trying to add 2 alarms?


#1405

Hey mate,

Well kinda yeah. I’m currently using this alarm which works great. The problem is that I now want to add my Arlo Surveillance solution, but unfortunately I can’t figure it out :frowning:.

I want to be able to arm and disarm my Arlo devices, but as it is right now I can only see the information about the cameras and whether they recording anything or not.

Maybe it’s not doable if I already use this Alarm from the post here?


#1406

Hmm, try this:

remove alarm.yaml, just for now to keep it simple. Then have configuration.yaml have this:

alarm_control_panel:
  - platform: arlo
  - platform: manual
    name: Manual Alarm

Restart and if it works, it works read on, if it doesnt, i can’t help you ^^

Now check the states page for the entity’s:

should be something like:

alarm_control_panel.manual_alarm
alarm_control_panel.arlo

Now you can add those to say lovelace. You can also automate different alarms see one of my configs below:

- alias: '[Alarm] Auto Disarm Alarm when home'
  hide_entity: false
  initial_state: 'on'
  trigger:
    - platform: state
      entity_id: device_tracker.ezras_iphone
      to: home
    - platform: state
      entity_id: device_tracker.ezra
      to: home
  action:
  - service: alarm_control_panel.alarm_disarm
    entity_id: alarm_control_panel.house
    data:
      code: !secret alarm

Note that for Arlo you should add some stuff, just scanned the info page:


#1407

Hi All,

I am getting below error after upgrading the HA to 0.85.1. Please help.

Whoops!

Something went wrong with your alarm component!

The following errors have been plucked from the Home Assistant log:

Invalid config for [alarm_control_panel.bwalarm]: [clock] is an invalid option for [alarm_control_panel.bwalarm]. Check: alarm_control_panel.bwalarm->clock. (See ?, line ?). Please check the docs at https://home-assistant.io/components/alarm_control_panel.bwalarm/

config.py (ERROR)

Home Assistant: v0.85.1

This Panel: v1.3.4

Thanks in advance.
RT


#1408

post your config of alarm_control_panel: & alarm.yaml
Try to disable the clock in your alarm.yaml


#1409

The problem is. Under the alarm.yaml file, is all my config for my alarm system.
So if I remove that I will lose my config.


#1410

No problem, just paste it under the - platform: manual (if it is for your manual one) or - platform: arlo (if its your arlo config)

alarm_control_panel:
  - platform: arlo
  - platform: manual
    name: Manual Alarm

Or just post everything you have and i’ll fix it for you.


#1411

I will post it here tomorrow so you can have a look. Basically what I have running now is what the guide told me. I downloaded the custom components and added the alarm.yaml file plus the library from github. Then I pasted all the standard automations into the automation.yaml file and then tweaked it. It is working almost flawless. But as stated above, now I want to add the arlo component as well.

I will add the configurations.yaml and alert.yaml file tomorrow.

Thanks man!


#1412

I get it no problem, we’ll figure it out with some trial and error :slight_smile:


#1413

Hi @eh50,

I have already disabled the clock in alarm.yaml as shown below.

##[INTERFACE OPTIONAL SETTINGS] 
#[OPTIONAL] - False by default. True enables a clock in the center of the status bar
clock: False  
#[OPTIONAL] - False by default. True enables perimeter mode, this could be known as 'Day Mode' i.e. only arm the doors whilst there is someone using all floors
perimeter_mode: True 
#[OPTIONAL] - False by Default. Allows a weather summary to be displayed on the status bar. Dark Sky weather component must be enabled with the name sensor.dark_sky_summary
weather: False 
#[OPTIONAL] False by Default. Allows this custom component to save the state of the alarm to file then reinstate it in the event of power loss.
persistence: False 
#[OPTIONAL] - True by default. This is a security feature when enabled hides the passcode while entering disarm code.
hide_passcode: True 
#[OPTIONAL] - False by default. This is a security feature when enabled hides the HA sidebar when the alarm is armed. The sidebar re-appears when the alarm is disarmed.
hide_sidebar: False 
#[OPTIONAL] - False by default. Setting this to True hides sensor groups (all sensors, immediate sensors, delayed sensors, inactive sensors) from the display. Open sensors will still appear
hide_sensor_groups: False 
#[OPTIONAL] - True by default. Setting this to False enables a custom panel below the sensors groups which allows you to add your own html code. Use this to bring any other features you would like to see for example displaying live camera feeds, a rotating image gallery, custom HA buttons and sensors. To use this enable the custom panel in alarm.yaml (custom_panel: True) then ensure you take a copy of custom-element.html and add it to you www/alarm/ folder. Edit the html code between the <template> tags. I'm have added a custom sample folder where I will upload examples of 'things' which can be added here. Please contribute!!!
hide_custom_panel: False 

Thanks,
RT


#1414

Home assistant log please. Also try to enable the clock? What about the time component, properly setup?


#1415

I to have the same error after updating alarm.py

2019-01-15 08:32:29 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don't require it, remove the 'api_password' from your http config. 2019-01-15 08:32:30 WARNING (MainThread) [homeassistant.loader] You are using a custom component for media_player.alexa which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant. 2019-01-15 08:32:31 WARNING (MainThread) [homeassistant.loader] You are using a custom component for alarm_control_panel.bwalarm which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant. 2019-01-15 08:32:31 ERROR (MainThread) [homeassistant.config] Invalid config for [alarm_control_panel.bwalarm]: [clock] is an invalid option for [alarm_control_panel.bwalarm]. Check: alarm_control_panel.bwalarm->clock. (See ?, line ?). Please check the docs at https://home-assistant.io/components/alarm_control_panel.bwalarm/ 2019-01-15 08:33:34 ERROR (MainThread) [frontend.js.latest.201901090] :0:0 Script error. 2019-01-15 08:33:45 ERROR (MainThread) [frontend.js.latest.201901090] :0:0 Script error. 2019-01-15 08:38:18 ERROR (MainThread) [homeassistant.components] Invalid config for [alarm_control_panel.bwalarm]: [clock] is an invalid option for [alarm_control_panel.bwalarm]. Check: alarm_control_panel.bwalarm->clock. (See ?, line ?). Please check the docs at https://home-assistant.io/components/alarm_control_panel.bwalarm/

checking the config fails and the log shows as above, I’ve tried with the clock set to true and false.


#1416

Did you only just update from a rather old version? I had to clear out my alarm.yaml when I updated to the latest version, and then use the GUI to set things back how my old alarm.yaml was


#1417

yes, that was it, didn’t realise the project had moved to a different setup, where do I find the gui to set the component up?


#1418

once you clear out the old alarm.yaml and go to the ‘alarm’ page in HA, it will all look different and have menu’s to do all the config


#1419


#1420

I was hoping you weren’t going to say that, no config options in that page

You may need to restart HA if the component doesn't load first time as HA will need to install a dependency (ruamel.yaml).

I see this on the readme, I can’t find that on my system so assume its related?