Youless sensor not add to energy dashboard

Hi there,

I use the Youless addon for home assistant. I have the LS110 model. I use this to read out my solar panels. I get two sensors:
sensor.energy_total and sensor.power_usage both sensors are working.

The problem is that i want to add the usage sensor to the default energy dashboard inside HA.
But it gave an error and the usage entity is even not selectable.

When i check the states
image

image
it looks fine, i change the W for KW, but that made no difference.

Any one an idea or is someone succesfully used it?

Words matter.

image

image

image

Hi Chris,

Thank you for your response. But that is not it.
Youless create two sensors:
sensor.power_usage, actual power
sensor.energy_total, total energy from the start.

They both cannot be selected in the energy dashboard. I see i added the wrong screenshot, but that was from a different kind of entity. The sensors from Youless cannot be found in the pull down list.

Remove it, then, because your OP makes no sense with it :wink:

You’ll definitely not be able to select sensor.power_usage, as the energy dashboard works on, well… energy.
Assuming you 2nd screenshot is for sensor.energy_total, seems fine to me.

You wouldn’t have excluded it from the recorder?

I think it was something with the recorder. I disabled it, restart and now i can add it without any problem
image
This is my setup. When i re-enable it i see also an old not existing entity in the list.

Thank you for pointing in the right direction.