Z-stick gen5 not adding nodes

new user here trying to set up GE Jasco switches with z-stick gen5. i configured the z-stick fine, and it shows up in z-wave js to mqtt. when i go to integrations and try to add a device, it fails. debug logs don’t provide any info except that it’s trying to add a node and that it fails. tried from phone app as well, and without any security, same deal.

if i unplug the stick and include the device manually everything is fine, but the device info is all null/dead in home assistant, and the docs say not to use this method any longer. similarly, i can exclude all of the devices using the stick mode. so the GE switches are there and fine, and i know how they should be paired, but i can’t get z-wave js to do a dang thing. any thoughts?

-SM-

You can do a successful reinterview of a node that you included using the stick? What’s your setup in terms of host device (VM, Raspberry, Odroid, etc) including versions, USB versions, SSD usage, ZStick 5 or 5+?

The non-plus stick doesn’t handle USB3.0 so it has to be in a USB2 port or USB2 non-powered hub.

thanks for the reply. i’m running ha blue. i updated core, supervisor, os to latest. i think i have the gen5 zstick. where did you see the note about usb 3? when i ordered everything like 9 months ago, the zstick gen5 was recommended as most successful, but obviously this is a moving target. i’d throw money at the problem, but i’m not even sure what the solution is at this point in ha land, and everything is out of stock anyway …

below is a silly log from add node. there’s a problem somewhere in the software stack. looks like interview and everything goes fine, then just nothing happens and no errors get logged. could be consistent with a usb problem, but i’m not sure where to look.

'2021-12-25T22:04:35.785Z DRIVER version 8.9.0-beta.1
2021-12-25T22:04:35.785Z DRIVER
2021-12-25T22:04:35.785Z DRIVER starting driver…
2021-12-25T22:04:35.790Z DRIVER opening serial port /dev/ttyACM0
2021-12-25T22:04:35.796Z DRIVER serial port opened
2021-12-25T22:04:35.796Z SERIAL » [NAK] (0x15)
2021-12-25T22:04:35.807Z DRIVER loading configuration…
2021-12-25T22:04:35.811Z CONFIG Using external configuration dir /data/db
2021-12-25T22:04:35.812Z CONFIG version 8.9.0-beta.1
2021-12-25T22:04:36.548Z CONFIG Priority device configuration directory /data/store/config not found
2021-12-25T22:04:36.583Z DRIVER beginning interview…
2021-12-25T22:04:36.584Z DRIVER added request handler for AddNodeToNetwork (0x4a)…
1 registered
2021-12-25T22:04:36.585Z DRIVER added request handler for RemoveNodeFromNetwork (0x4b)…
1 registered
2021-12-25T22:04:36.585Z DRIVER added request handler for ReplaceFailedNode (0x63)…
1 registered
2021-12-25T22:04:36.585Z CNTRLR querying controller IDs…
2021-12-25T22:04:36.601Z SERIAL » 0x01030020dc (5 bytes)
2021-12-25T22:04:36.603Z DRIVER » [REQ] [GetControllerId]
2021-12-25T22:04:36.606Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.608Z SERIAL « 0x01080120d1e6693b01b2 (10 bytes)
2021-12-25T22:04:36.609Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.611Z DRIVER « [RES] [GetControllerId]
payload: 0xd1e6693b01
2021-12-25T22:04:36.619Z CNTRLR received controller IDs:
home ID: 0xd1e6693b
own node ID: 1
2021-12-25T22:04:36.619Z CNTRLR querying API capabilities…
2021-12-25T22:04:36.626Z SERIAL » 0x01030007fb (5 bytes)
2021-12-25T22:04:36.627Z DRIVER » [REQ] [GetSerialApiCapabilities]
2021-12-25T22:04:36.629Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.631Z SERIAL « 0x012b0107010100860101005afe81ff884f1f0000fb9f7da067000080008086000 (45 bytes)
000e87300000e0000600000fb
2021-12-25T22:04:36.632Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.633Z DRIVER « [RES] [GetSerialApiCapabilities]
payload: 0x010100860101005afe81ff884f1f0000fb9f7da067000080008086000000e8730
0000e0000600000
2021-12-25T22:04:36.638Z CNTRLR received API capabilities:
serial API version: 1.1
manufacturer ID: 0x86
product type: 0x0101
product ID: 0x5a
supported functions:
· GetSerialApiInitData (0x02)
· FUNC_ID_SERIAL_API_APPL_NODE_INFORMATION (0x03)
· ApplicationCommand (0x04)
· GetControllerCapabilities (0x05)
· SetSerialApiTimeouts (0x06)
· GetSerialApiCapabilities (0x07)
· SoftReset (0x08)
· UNKNOWN_FUNC_UNKNOWN_0x09 (0x09)
· SetRFReceiveMode (0x10)
· UNKNOWN_FUNC_SET_SLEEP_MODE (0x11)
· FUNC_ID_ZW_SEND_NODE_INFORMATION (0x12)
· SendData (0x13)
· SendDataMulticast (0x14)
· GetControllerVersion (0x15)
· SendDataAbort (0x16)
· FUNC_ID_ZW_R_F_POWER_LEVEL_SET (0x17)
· UNKNOWN_FUNC_SEND_DATA_META (0x18)
· FUNC_ID_ZW_GET_RANDOM (0x1c)
· GetControllerId (0x20)
· UNKNOWN_FUNC_MEMORY_GET_BYTE (0x21)
· UNKNOWN_FUNC_MEMORY_PUT_BYTE (0x22)
· UNKNOWN_FUNC_MEMORY_GET_BUFFER (0x23)
· UNKNOWN_FUNC_MEMORY_PUT_BUFFER (0x24)
· UNKNOWN_FUNC_FlashAutoProgSet (0x27)
· GetNVMId (0x29)
· ExtNVMReadLongBuffer (0x2a)
· ExtNVMWriteLongBuffer (0x2b)
· ExtNVMReadLongByte (0x2c)
· ExtExtWriteLongByte (0x2d)
· GetNodeProtocolInfo (0x41)
· HardReset (0x42)
· FUNC_ID_ZW_REPLICATION_COMMAND_COMPLETE (0x44)
· FUNC_ID_ZW_REPLICATION_SEND_DATA (0x45)
· AssignReturnRoute (0x46)
· DeleteReturnRoute (0x47)
· RequestNodeNeighborUpdate (0x48)
· ApplicationUpdateRequest (0x49)
· AddNodeToNetwork (0x4a)
· RemoveNodeFromNetwork (0x4b)
· FUNC_ID_ZW_CREATE_NEW_PRIMARY (0x4c)
· FUNC_ID_ZW_CONTROLLER_CHANGE (0x4d)
· FUNC_ID_ZW_SET_LEARN_MODE (0x50)
· AssignSUCReturnRoute (0x51)
· FUNC_ID_ZW_REQUEST_NETWORK_UPDATE (0x53)
· SetSUCNodeId (0x54)
· DeleteSUCReturnRoute (0x55)
· GetSUCNodeId (0x56)
· UNKNOWN_FUNC_SEND_SUC_ID (0x57)
· FUNC_ID_ZW_EXPLORE_REQUEST_INCLUSION (0x5e)
· RequestNodeInfo (0x60)
· RemoveFailedNode (0x61)
· IsFailedNode (0x62)
· ReplaceFailedNode (0x63)
· UNKNOWN_FUNC_UNKNOWN_0x66 (0x66)
· UNKNOWN_FUNC_UNKNOWN_0x67 (0x67)
· GetRoutingInfo (0x80)
· UNKNOWN_FUNC_LOCK_ROUTE_RESPONSE (0x90)
· UNKNOWN_FUNC_GET_PRIORITY_ROUTE (0x92)
· UNKNOWN_FUNC_SET_PRIORITY_ROUTE (0x93)
· UNKNOWN_FUNC_UNKNOWN_0x98 (0x98)
· UNKNOWN_FUNC_UNKNOWN_0xB4 (0xb4)
· UNKNOWN_FUNC_WATCH_DOG_ENABLE (0xb6)
· UNKNOWN_FUNC_WATCH_DOG_DISABLE (0xb7)
· UNKNOWN_FUNC_WATCH_DOG_KICK (0xb8)
· UNKNOWN_FUNC_UNKNOWN_0xB9 (0xb9)
· UNKNOWN_FUNC_RF_POWERLEVEL_GET (0xba)
· UNKNOWN_FUNC_GET_LIBRARY_TYPE (0xbd)
· UNKNOWN_FUNC_SEND_TEST_FRAME (0xbe)
· UNKNOWN_FUNC_GET_PROTOCOL_STATUS (0xbf)
· UNKNOWN_FUNC_UNKNOWN_0xD2 (0xd2)
· UNKNOWN_FUNC_UNKNOWN_0xD3 (0xd3)
· UNKNOWN_FUNC_UNKNOWN_0xD4 (0xd4)
· undefined (0xee)
· UNKNOWN_FUNC_UNKNOWN_0xEF (0xef)
2021-12-25T22:04:36.656Z CNTRLR querying version info…
2021-12-25T22:04:36.663Z SERIAL » 0x01030015e9 (5 bytes)
2021-12-25T22:04:36.663Z DRIVER » [REQ] [GetControllerVersion]
2021-12-25T22:04:36.665Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.666Z SERIAL « 0x011001155a2d5761766520342e3534000193 (18 bytes)
2021-12-25T22:04:36.667Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.668Z DRIVER « [RES] [GetControllerVersion]
payload: 0x5a2d5761766520342e35340001
2021-12-25T22:04:36.672Z CNTRLR received version info:
controller type: Static Controller
library version: Z-Wave 4.54
2021-12-25T22:04:36.674Z CNTRLR supported Z-Wave features:
2021-12-25T22:04:36.674Z CNTRLR querying controller capabilities…
2021-12-25T22:04:36.680Z SERIAL » 0x01030005f9 (5 bytes)
2021-12-25T22:04:36.681Z DRIVER » [REQ] [GetControllerCapabilities]
2021-12-25T22:04:36.682Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.684Z SERIAL « 0x010401053cc3 (6 bytes)
2021-12-25T22:04:36.685Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.686Z DRIVER « [RES] [GetControllerCapabilities]
payload: 0x3c
2021-12-25T22:04:36.691Z CNTRLR received controller capabilities:
controller role: primary
is in other network: false
is SIS present: true
was real primary: true
is a SUC: true
2021-12-25T22:04:36.691Z CNTRLR finding SUC…
2021-12-25T22:04:36.701Z SERIAL » 0x01030056aa (5 bytes)
2021-12-25T22:04:36.702Z DRIVER » [REQ] [GetSUCNodeId]
2021-12-25T22:04:36.703Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.705Z SERIAL « 0x0104015601ad (6 bytes)
2021-12-25T22:04:36.706Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.707Z DRIVER « [RES] [GetSUCNodeId]
payload: 0x01
2021-12-25T22:04:36.711Z CNTRLR This is the SUC
2021-12-25T22:04:36.711Z CNTRLR querying node information…
2021-12-25T22:04:36.718Z SERIAL » 0x01030002fe (5 bytes)
2021-12-25T22:04:36.719Z DRIVER » [REQ] [GetSerialApiInitData]
2021-12-25T22:04:36.721Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.818Z SERIAL « 0x0125010205081d010000000000000000000000000000000000000000000000000 (39 bytes)
00000000500cd
2021-12-25T22:04:36.819Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.820Z DRIVER « [RES] [GetSerialApiInitData]
payload: 0x05081d01000000000000000000000000000000000000000000000000000000000
500
2021-12-25T22:04:36.824Z CNTRLR received node information:
controller role: primary
controller is a SUC: true
controller is a slave: false
controller supports timers: false
nodes in the network: 1
2021-12-25T22:04:36.831Z DRIVER Cache file for homeId 0xd1e6693b found, attempting to restore the network from
cache…
2021-12-25T22:04:36.845Z CNTRLR [Node 001] Embedded device config loaded
2021-12-25T22:04:36.846Z DRIVER Restoring the network from cache was successful!
2021-12-25T22:04:36.850Z CNTRLR [Node 001] [Manufacturer Specific] manufacturerId: metadata updated
2021-12-25T22:04:36.850Z CNTRLR [Node 001] [Manufacturer Specific] productType: metadata updated
2021-12-25T22:04:36.851Z CNTRLR [Node 001] [Manufacturer Specific] productId: metadata updated
2021-12-25T22:04:36.853Z CNTRLR [Node 001] [~] [Manufacturer Specific] manufacturerId: 134 => 134
2021-12-25T22:04:36.854Z CNTRLR [Node 001] [~] [Manufacturer Specific] productType: 257 => 257
2021-12-25T22:04:36.854Z CNTRLR [Node 001] [~] [Manufacturer Specific] productId: 90 => 90
2021-12-25T22:04:36.855Z CNTRLR [Node 001] [Version] firmwareVersions: metadata updated
2021-12-25T22:04:36.856Z CNTRLR [Node 001] [~] [Version] firmwareVersions: 1.1 => 1.1
2021-12-25T22:04:36.856Z CNTRLR setting serial API timeouts: ack = 1000 ms, byte = 150 ms
2021-12-25T22:04:36.863Z SERIAL » 0x01050006640f97 (7 bytes)
2021-12-25T22:04:36.863Z DRIVER » [REQ] [SetSerialApiTimeouts]
payload: 0x640f
2021-12-25T22:04:36.868Z SERIAL « [ACK] (0x06)
2021-12-25T22:04:36.869Z SERIAL « 0x01050106640f96 (7 bytes)
2021-12-25T22:04:36.870Z SERIAL » [ACK] (0x06)
2021-12-25T22:04:36.871Z DRIVER « [RES] [SetSerialApiTimeouts]
payload: 0x640f
2021-12-25T22:04:36.875Z CNTRLR serial API timeouts overwritten. The old values were: ack = 1000 ms, byte = 15
0 ms
2021-12-25T22:04:36.875Z CNTRLR Interview completed
2021-12-25T22:04:36.875Z DRIVER Network key for S0 configured, enabling S0 security manager…
2021-12-25T22:04:36.876Z DRIVER At least one network key for S2 configured, enabling S2 security manager…
2021-12-25T22:04:36.880Z DRIVER driver ready
2021-12-25T22:04:36.882Z DRIVER Checking for configuration updates…
2021-12-25T22:04:36.897Z CNTRLR [Node 001] The node is alive.
2021-12-25T22:04:36.900Z CNTRLR [Node 001] The node is ready to be used
2021-12-25T22:04:36.900Z CNTRLR All nodes are ready to be used
2021-12-25T22:04:37.129Z DRIVER No configuration update available…
2021-12-25T22:04:38.015Z DRIVER Usage statistics sent - next transmission scheduled in 23 hours.

The issue is described on multiple places, but here’s some reference material. It really depends on the actual version of the stick.

Pi4 && Aeotec Z-Wave USB Stick Gen5 - Raspberry Pi Forums

AEOTEC USB Zwave module not creating /dev/ttyACM0 · Issue #3027 · raspberrypi/linux (github.com)

Z-Stick Gen5 technical specifications. : Aeotec Help Desk (freshdesk.com)

thanks, i googled around yesterday and saw the problem discussed. kinda amazed aeotec would do something like that, but there you go. not sure it’s my problem, since at this point i don’t have any diagnostics to help. i don’t have a usb cable handy, because it’s not the 90’s. i ordered the zooz 700 stick, so we’ll see how that works in a couple days.

update. zooz 700 arrived today and worked right out of the box. happy me. suck it aeotec. thanks for the help.

can i configure the craptastic z-stick as a gateway or something, or is it just trash?

You can use the extra USB stick as a test network. You can use it to exclude devices independently of the other controller. You can turn it into a Zniffer to monitor Z-Wave traffic. I did that with mine, although the range seemed to not be very good for some reason (UZB3 is working better for this purpose).

You may even be able to sell it for something. Some people are looking to downgrade back to 500-series from 700 because the 700 controllers are unusable in certain networks. You might want to keep it around in case you run into the same problem, or just as general backup stick.